File: parseyaml_spec.rb

package info (click to toggle)
puppet-module-puppetlabs-stdlib 5.0.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 2,804 kB
  • sloc: ruby: 16,417; sh: 46; makefile: 2
file content (83 lines) | stat: -rw-r--r-- 3,121 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
require 'spec_helper'

describe 'parseyaml' do
  it 'exists' do
    is_expected.not_to eq(nil)
  end

  it 'raises an error if called without any arguments' do
    is_expected.to run.with_params
                      .and_raise_error(%r{wrong number of arguments}i)
  end

  context 'with correct YAML data' do
    it 'is able to parse a YAML data with a String' do
      actual_array = ['--- just a string', 'just a string']
      actual_array.each do |actual|
        is_expected.to run.with_params(actual).and_return('just a string')
      end
    end

    it 'is able to parse YAML data with a Hash' do
      is_expected.to run.with_params("---\na: '1'\nb: '2'\n")
                        .and_return('a' => '1', 'b' => '2')
    end

    it 'is able to parse YAML data with an Array' do
      is_expected.to run.with_params("---\n- a\n- b\n- c\n")
                        .and_return(['a', 'b', 'c'])
    end

    it 'is able to parse YAML data with a mixed structure' do
      is_expected.to run.with_params("---\na: '1'\nb: 2\nc:\n  d:\n  - :a\n  - true\n  - false\n")
                        .and_return('a' => '1', 'b' => 2, 'c' => { 'd' => [:a, true, false] })
    end

    it 'is able to parse YAML data with a UTF8 and double byte characters' do
      is_expected.to run.with_params("---\na: ×\nこれ: 記号\nです:\n  ©:\n  - Á\n  - ß\n")
                        .and_return('a' => '×', 'これ' => '記号', 'です' => { '©' => ['Á', 'ß'] })
    end

    it 'does not return the default value if the data was parsed correctly' do
      is_expected.to run.with_params("---\na: '1'\n", 'default_value')
                        .and_return('a' => '1')
    end
  end

  context 'on a modern ruby', :unless => RUBY_VERSION == '1.8.7' do
    it 'raises an error with invalid YAML and no default' do
      is_expected.to run.with_params('["one"')
                        .and_raise_error(Psych::SyntaxError)
    end
  end

  context 'when running on ruby 1.8.7, which does not have Psych', :if => RUBY_VERSION == '1.8.7' do
    it 'raises an error with invalid YAML and no default' do
      is_expected.to run.with_params('["one"')
                        .and_raise_error(ArgumentError)
    end
  end

  context 'with incorrect YAML data' do
    it 'supports a structure for a default value' do
      is_expected.to run.with_params('', 'a' => '1')
                        .and_return('a' => '1')
    end

    [1, 1.2, nil, true, false, [], {}, :yaml].each do |value|
      it "should return the default value for an incorrect #{value.inspect} (#{value.class}) parameter" do
        is_expected.to run.with_params(value, 'default_value')
                          .and_return('default_value')
      end
    end

    context 'when running on modern rubies', :unless => RUBY_VERSION == '1.8.7' do
      ['---', '...', '*8', ''].each do |value|
        it "should return the default value for an incorrect #{value.inspect} string parameter" do
          is_expected.to run.with_params(value, 'default_value')
                            .and_return('default_value')
        end
      end
    end
  end
end