File: metadata.json

package info (click to toggle)
puppet-module-puppetlabs-vcsrepo 1.3.2-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, stretch
  • size: 836 kB
  • ctags: 119
  • sloc: ruby: 6,359; sh: 49; makefile: 15
file content (80 lines) | stat: -rw-r--r-- 1,581 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
{
  "name": "puppetlabs-vcsrepo",
  "version": "1.3.2",
  "author": "Puppet Labs",
  "summary": "Puppet module providing a type to manage repositories from various version control systems",
  "license": "GPLv2",
  "source": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
  "project_page": "https://github.com/puppetlabs/puppetlabs-vcsrepo",
  "issues_url": "https://tickets.puppetlabs.com/browse/MODULES",
  "dependencies": [
  
  ],
  "operatingsystem_support": [
    {
      "operatingsystem": "RedHat",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "CentOS",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "OracleLinux",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "Scientific",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "SLES",
      "operatingsystemrelease": [
        "10 SP4",
        "11 SP1",
        "12"
      ]
    },
    {
      "operatingsystem": "Debian",
      "operatingsystemrelease": [
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "Ubuntu",
      "operatingsystemrelease": [
        "10.04",
        "12.04",
        "14.04"
      ]
    }
  ],
  "requirements": [
    {
      "name": "pe",
      "version_requirement": ">= 3.0.0 < 2015.4.0"
    },
    {
      "name": "puppet",
      "version_requirement": ">= 3.0.0 < 5.0.0"
    }
  ]
}