File: spec_helper.rb

package info (click to toggle)
puppet-module-puppetlabs-vcsrepo 1.3.2-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, stretch
  • size: 836 kB
  • ctags: 119
  • sloc: ruby: 6,359; sh: 49; makefile: 15
file content (16 lines) | stat: -rw-r--r-- 356 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
require 'puppetlabs_spec_helper/module_spec_helper'
require 'support/filesystem_helpers'
require 'support/fixture_helpers'

# SimpleCov does not run on Ruby 1.8.7
unless RUBY_VERSION.to_f < 1.9
  require 'simplecov'
  SimpleCov.start do
    add_filter '/spec/'
  end
end

RSpec.configure do |c|
  c.include FilesystemHelpers
  c.include FixtureHelpers
end