File: Gemfile

package info (click to toggle)
puppet-strings 2.5.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 1,336 kB
  • sloc: ruby: 7,285; makefile: 12
file content (51 lines) | stat: -rw-r--r-- 1,258 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
source ENV['GEM_SOURCE'] || "https://rubygems.org"

gemspec

gem 'rgen'
gem 'redcarpet'
gem 'yard', '~> 0.9.11'

if ENV['PUPPET_GEM_VERSION']
  gem 'puppet', ENV['PUPPET_GEM_VERSION'], :require => false
else
  gem 'puppet', :require => false
end

group :test do
  gem 'codecov'
  gem 'mocha'
  gem 'puppetlabs_spec_helper'
  gem 'serverspec'
  gem 'simplecov-console'
  gem 'rspec', '~> 3.1'
  gem 'json_spec', '~> 1.1', '>= 1.1.5'
  gem 'mdl', '~> 0.8.0' if Gem::Version.new(RUBY_VERSION.dup) >= Gem::Version.new('2.4.0')
end

group :acceptance do
  # Litmus has dependencies which require Ruby 2.5 (Puppet 6) or above.
  if Gem::Version.new(RUBY_VERSION.dup) >= Gem::Version.new('2.5.0')
    gem 'puppet_litmus', '~> 0.18'
    gem 'net-ssh', '~> 5.2'
  end
end

group :development do
  gem 'github_changelog_generator', '~> 1.15' if Gem::Version.new(RUBY_VERSION.dup) >= Gem::Version.new('2.3.0')
  gem 'pry'
  gem 'pry-byebug'
end

gem 'rubocop-rspec'
gem 'rubocop', '~> 0.57.2'

# Evaluate Gemfile.local if it exists
if File.exists? "#{__FILE__}.local"
  eval(File.read("#{__FILE__}.local"), binding)
end

# Evaluate ~/.gemfile if it exists
if File.exists?(File.join(Dir.home, '.gemfile'))
  eval(File.read(File.join(Dir.home, '.gemfile')), binding)
end