File: fact_name.rb

package info (click to toggle)
puppet 3.7.2-4+deb8u1
  • links: PTS, VCS
  • area: main
  • in suites: jessie
  • size: 18,912 kB
  • ctags: 13,168
  • sloc: ruby: 210,410; sh: 2,050; xml: 1,554; lisp: 300; makefile: 142; python: 108; sql: 103; yacc: 72
file content (10 lines) | stat: -rw-r--r-- 312 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
require 'active_record'
if Gem::Version.new(ActiveRecord::VERSION::STRING) >= Gem::Version.new('4.1')
  require 'active_record/deprecated_finders'
end
require 'puppet/rails'
require 'puppet/rails/fact_value'

class Puppet::Rails::FactName < ActiveRecord::Base
  has_many :fact_values, :dependent => :destroy
end