1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
|
From: Ole Streicher <olebole@debian.org>
Date: Thu, 12 Sep 2024 14:31:26 +0200
Subject: Disable long-running tests
cpp/tests/CMakeLists.txt | 7 -------
1 file changed, 7 deletions(-)
diff --git a/cpp/tests/CMakeLists.txt b/cpp/tests/CMakeLists.txt
index 2192913..46acd9b 100644
@@ -20,13 +20,11 @@ target_include_directories(common_catch_main_object PUBLIC
file(MAKE_DIRECTORY "${PROJECT_BINARY_DIR}/outputs")
-add_catch_test(algo_factory LIBRARIES libpurify)
add_catch_test(convolution LIBRARIES libpurify)
add_catch_test(distribute LIBRARIES libpurify)
add_catch_test(index_mapping LIBRARIES libpurify)
add_catch_test(integration LIBRARIES libpurify)
add_catch_test(measurement_factory LIBRARIES libpurify)
-add_catch_test(measurement_operator LIBRARIES libpurify)
add_catch_test(operators LIBRARIES libpurify)
add_catch_test(parser_test LIBRARIES libpurify)
add_catch_test(purify_fitsio LIBRARIES libpurify)
@@ -34,7 +32,6 @@ add_catch_test(read_measurements LIBRARIES libpurify)
add_catch_test(sparse LIBRARIES libpurify)
add_catch_test(utils LIBRARIES libpurify)
add_catch_test(uvfits LIBRARIES libpurify)
-add_catch_test(wavelet_factory LIBRARIES libpurify)
add_catch_test(wide_field_utilities LIBRARIES libpurify)
add_catch_test(wkernel LIBRARIES libpurify)
@@ -81,10 +78,6 @@ if(PURIFY_MPI)
endfunction()
add_mpi_test(distribute_sparse_vector LIBRARIES libpurify)
- add_mpi_test(kmeans LIBRARIES libpurify)
- add_mpi_test(mpi_algo_factory LIBRARIES libpurify)
- add_mpi_test(mpi_measurement_factory LIBRARIES libpurify)
- add_mpi_test(mpi_measurement_operator LIBRARIES libpurify)
add_mpi_test(mpi_read_measurements LIBRARIES libpurify)
add_catch_test(mpi_utilities LIBRARIES libpurify)
add_mpi_test(mpi_wavelet_factory LIBRARIES libpurify)
|