File: README

package info (click to toggle)
pybliographer 1.2.9-1
  • links: PTS
  • area: main
  • in suites: etch, etch-m68k
  • size: 3,528 kB
  • ctags: 1,399
  • sloc: python: 9,788; xml: 2,573; makefile: 609; sh: 597
file content (56 lines) | stat: -rw-r--r-- 1,453 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
-*- text -*-
=================================================================

Pybliographer provides a framework for working with bibliographic
databases.

For more information, please consult the documentation at:

	http://pybliographer.org/

=================================================================


* Requirements
  ------------

Before installing pybliographer, please install:

       
  - GNU Recode (v. 3.5)
  - python-bibtex (also available from http://pybliographer.org/)
  - Gnome 2.x and gnome-python 2.x


* Installation 
  ------------

Basically, it should be a matter of:

	./configure && make
	su
	make install

You can then run several programs :

  - pybliographic : the graphical interface
  - pybliographer : the text-based interface and scripting language
  - pybcheck, pybconvert, pybformat, ... : several useful tools

For more configuration options, have a look at the output of ./configure --help

* Troubleshooting
  ---------------

If the configure script reports the following errors:

 ** "error in python modules dependencies:  No module named ..."
 
   This means that a required module is not installed. Unfortunately,
   depending on your distribution, the actual package to install can
   be named differently. Check on the help pages of your distribution.

 ** "broken recode version"

   Your recode package does not behave properly.  Consult
   http://pybliographer.org/RecodeHelp for more information.