1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --with python3,sphinxdoc --buildsystem=meson
override_dh_auto_configure:
$(foreach PYVERSION,$(shell py3versions -s),dh_auto_configure --builddir=obj-$(PYVERSION) -- -Dpython=$(PYVERSION); )
override_dh_auto_build:
$(foreach PYVERSION,$(shell py3versions -s),dh_auto_build --builddir=obj-$(PYVERSION) -- ; )
override_dh_auto_install:
$(foreach PYVERSION,$(shell py3versions -s),dh_auto_install --builddir=obj-$(PYVERSION) -- ; )
override_dh_auto_test-indep:
override_dh_auto_test:
$(foreach PYVERSION,$(shell py3versions -s),dh_auto_test --builddir=obj-$(PYVERSION) -- ; )
execute_after_dh_auto_build-indep:
python3 -m sphinx -bhtml docs debian/tmp-doc/html
sed -ir 's|src="https:[^"]*|src="|' debian/tmp-doc/html/index.html
execute_after_dh_auto_clean:
rm -rf debian/tmp-doc
# https://bugs.debian.org/1034520
override_dh_installchangelogs:
dh_installchangelogs -Xchangelog
|