1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82
|
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=pydevd
ifneq (,$(filter $(DEB_HOST_ARCH), alpha ia64 x32))
export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
else
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
endif
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
%:
dh $@ --buildsystem=pybuild
_pydevd_bundle/pydevd_runpy.py:
libdir=/usr/lib/$$(py3versions --min-supported); \
cp $$libdir/runpy.py _pydevd_bundle/pydevd_runpy.py
patch -p1 < debian/runpy.patch
_pydevd_frame_eval/vendored/bytecode/__init__.py:
cd _pydevd_frame_eval/vendored && \
cp -a /usr/lib/python3/dist-packages/bytecode . && \
python3 pydevd_fix_code.py
execute_before_dh_auto_clean: _pydevd_bundle/pydevd_runpy.py _pydevd_frame_eval/vendored/bytecode/__init__.py
execute_after_dh_clean:
rm -f _pydevd_bundle/pydevd_runpy.py
rm -rf _pydevd_frame_eval/vendored/bytecode
execute_before_dh_auto_configure: _pydevd_bundle/pydevd_runpy.py _pydevd_frame_eval/vendored/bytecode/__init__.py
override_dh_auto_build:
cd pydevd_attach_to_process/linux_and_mac && \
g++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -shared \
-o ../attach.so -fPIC -nostartfiles attach.cpp
PYBUILD_AFTER_BUILD="cd {build_dir}; {interpreter} setup_pydevd_cython.py build_ext --inplace --force-cython || true" \
dh_auto_build --buildsystem=pybuild
txt2man -t pydevd -P pname -r "pydevd-$(DEB_VERSION_UPSTREAM)" -s 1 -v "" -d "July 2022" debian/manpage/pydevd.txt > debian/manpage/pydevd.1
override_dh_python3:
dh_python3 --no-ext-rename
echo "pydevd:Built-Using=python-bytecode (= $$(dpkg-query -f='$${Version}' -W python3-bytecode))" >> debian/python3-pydevd.substvars
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
compiled=$(shell build_dir=$$(pybuild --print build_dir | cut -d: -f2 | cut -c2-); ls $$build_dir/_pydevd_bundle | grep 'pydevd_cython.*.so'); \
export http_proxy=""; \
export PYBUILD_SYSTEM=custom; \
export PYBUILD_TEST_ARGS="\
cd {build_dir}; \
if [ -n \"$$compiled\" ]; then \
export PYDEVD_USE_CYTHON=YES; else \
export PYDEVD_USE_CYTHON=NO; fi; \
$(CURDIR)/debian/run_tests $(CURDIR)/debian/get_test_exclusions {interpreter} -m pytest \
--deselect=tests_python/test_debugger.py::test_matplotlib_activation \
--deselect=tests_python/test_debugger_json.py::test_pandas"; \
xvfb-run -a dh_auto_test
endif
|