File: changelog

package info (click to toggle)
pydoctor 19.11.0%2Bgit20200303.47424e7-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 1,400 kB
  • sloc: python: 6,290; makefile: 11; sh: 8
file content (232 lines) | stat: -rw-r--r-- 8,336 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
pydoctor (19.11.0+git20200303.47424e7-1) unstable; urgency=medium

  * New upstream version 19.11.0+git20200303.47424e7
  * debian/gbp.conf: Set debian-branch to debian/master for DEP-14 conformance
  * Add "export PYBUILD_NAME := pydoctor" in debian/rules
    and remove transitional package python-doctor
    and delete debian/pydoctor.install so that
    pybuild installs all files to the binary pydoctor package correctly
  * Run custom tests specified in upstream tox.ini and install
    python3-{coverage,hypothesis,incremental,pytest,twisted,flakes}
    and add debian/pybuild.testfiles for the tests to work
  * Add debian/tests/control and debian/tests/pydoctor for autopkgtest
  * debian/clean: Clean up .pytest_cache/ too
  * Install missing sources for bootstrap.min.css from bootstrap-3.3.4/less
    downloaded from https://github.com/twbs/bootstrap/archive/v3.3.4.tar.gz ,
    see https://lists.debian.org/debian-devel/2020/03/msg00027.html
  * Fix typos in debian/pydoctor.1 and debian/README.Debian

 -- Anthony Fok <foka@debian.org>  Thu, 05 Mar 2020 14:42:38 -0700

pydoctor (19.11.0+git20200114.c74016b-2) unstable; urgency=medium

  * Remove empty debian/patches/series file
  * Add missing embedded epydoc and Bootstrap copyright info
    as well as non-minified source for bootstrap.min.css (Bootstrap v3.3.4)
    for DFSG compliance.  Special thanks to Sean Whitton for the report.
    (Closes: #952546)
  * Also expand pydoctor copyright info:
     - Update Michael Hudson’s name to Michael Hudson-Doyle
     - Add Maarten ter Huurne
  * Fix empty package by adding debian/pydoctor.install
  * Symlink to bootstrap.min.css from libjs-bootstrap instead of shipping
    pydoctor included bootstrap.min.css v3.3.4 from 2015
  * Add debian/clean to remove pydoctor.egg-info/
  * Add myself to the list of Uploaders and to debian/copyright

 -- Anthony Fok <foka@debian.org>  Tue, 25 Feb 2020 16:00:02 -0700

pydoctor (19.11.0+git20200114.c74016b-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 19.11.0+git20200114.c74016b
  * debian/watch: Track HEAD on GitHub for now for python3 compatibility.
  * Apply "cme fix dpkg" fixes:
    - Bump Standards-Version to 4.5.0 (no change)
    - Reformat debian/control for easier human reading
    - Change license shortname "MIT" to "Expat" in debian/copyright
  * Remove dependency on python-nevow which upstream has stopped using
    since 2013.
  * Switch to Python 3, and rename binary package to pydoctor
    because it is a Python application and not used as a module.
    Also add explicit dependency on python3-lockfile as recommended
    by Andrej Shadura. (Closes: #937421, #948831, #949232)
  * debian/rules: Change "dh $*" to "dh $@" (Lintian I: no-dh-sequencer)

 -- Anthony Fok <foka@debian.org>  Sun, 23 Feb 2020 07:34:00 -0700

pydoctor (19.11.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field
  * Remove debian/pycompat, it's not used by any modern Python helper
  * d/control: Add Vcs-* field
  * Use debhelper-compat instead of debian/compat.
  * d/changelog: Remove trailing whitespaces.
  * d/control: Fix wrong Vcs-*.

  [ Debian Janitor ]
  * Trim trailing whitespace.
  * Remove obsolete debian/pyversions.
  * Bump debhelper from old 9 to 12.
  * Set upstream metadata fields: Repository.
  * Set upstream metadata fields: Repository-Browse.

  [ Jelmer Vernooij ]
  * Drop unnecessary bzr-builddeb file.
  * New upstream release.
   + Add build-dependency on python-incremental.
  * Bump standards version to 4.4.1.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 15 Dec 2019 13:50:31 +0000

pydoctor (16.3.0-2.1) unstable; urgency=medium

  * Non-maintainer upload
  * Remove dependency on epydoc (closes: #881550, #932584)
    - Add debian/README.Debian explaining this change
    - Adjust debian/control to remove Depends on python-epydoc
    - Adjust setup.py and setup.cfg to remove reference to epydoc

 -- Kenneth J. Pronovici <pronovic@debian.org>  Tue, 30 Jul 2019 23:07:46 +0000

pydoctor (16.3.0-2) unstable; urgency=medium

  * Add missing dependency on dh-python.
  * Bump standards version to 4.1.4.
  * Change maintainer to Python Application Packaging Team. Closes: #899661
  * Move Vcs-Git to salsa.
  * Set homepage field. Thanks, Chris Lamb. Closes: #884255

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 02 Jun 2018 13:30:18 +0100

pydoctor (16.3.0-1) unstable; urgency=medium

  * New upstream version.
  * Change debhelper compatibility to 9.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 22 Jan 2017 16:38:19 +0000

pydoctor (15.1.0-1) unstable; urgency=medium

  * New upstream release.
  * Remove fix-unicode.diff: applied upstream.
  * Update watch file.
  * Bump standards version to 3.9.8 (no changes).
  * Drop -b unstable from Vcs-Git header.
  * Drop source-date-epoch patch: applied upstream.
  * Drop patch fix-unicode.diff: applied upstream.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 03 Jul 2016 21:22:01 +0000

pydoctor (0.5+git20151204-2) unstable; urgency=medium

  * Add patch fix-unicode.diff, to hack in support for newer versions of
    twisted. Closes: #807088

 -- Jelmer Vernooij <jelmer@debian.org>  Tue, 08 Dec 2015 00:30:58 +0000

pydoctor (0.5+git20151204-1) unstable; urgency=medium

  * New upstream snapshot.
  * Bump standards version to 3.9.6 (no changes).
  * Change Vcs header to Git.
  * Add build dependency on python-setuptools.
  * Add patch source-date-epoch.diff: Support SOURCE_DATE_EPOCH environment
    variable. Closes: #807166

 -- Jelmer Vernooij <jelmer@debian.org>  Fri, 04 Dec 2015 23:24:07 +0000

pydoctor (0.5+git20150410-2) unstable; urgency=medium

  * Upload to unstable.

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 25 Apr 2015 15:16:25 +0000

pydoctor (0.5+git20150410-1) experimental; urgency=medium

  * New upstream snapshot.
    + Makes output reproducible. Closes: #776783
  * Fix watch file.

 -- Jelmer Vernooij <jelmer@debian.org>  Tue, 22 Jul 2014 03:36:12 +0200

pydoctor (0.5+bzr616-1) unstable; urgency=medium

  * New upstream snapshot.
  * Bump standards version to 3.9.5 (no changes).
  * Fix Vcs-Bzr URL.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 06 Jul 2014 05:10:40 +0200

pydoctor (0.5b1+bzr603-1) unstable; urgency=low

  * New upstream snapshot.
  * Switch from cdbs to dh.
  * Bump standards version to 3.9.4 (no changes).
  * Update Vcs header.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 15 Sep 2013 13:58:49 +0100

pydoctor (0.3+bzr567-1) unstable; urgency=low

  * Drop Guido from uploaders per his request.
  * New upstream snapshot.
   + Add basic support for introspection. Closes: #538984
  * Bump standards version to 3.9.1 (no changes).
  * Add watch file.

 -- Jelmer Vernooij <jelmer@debian.org>  Mon, 06 Dec 2010 17:52:23 +0100

pydoctor (0.3-1) unstable; urgency=low

  * New upstream release.
  * Add myself to uploaders.
  * Bump standards version to 3.8.4.
  * Use source format 3.

 -- Jelmer Vernooij <jelmer@debian.org>  Mon, 29 Mar 2010 16:46:14 +0200

pydoctor (0.2-4.1) unstable; urgency=low

  * Non-maintainer upload.
  * pydoctor/ast_pp.py
    - applied patch from upstream to add compatibility with Python 2.6; thanks
      to Seo Sanghyeon for the report; Closes: #539600
  * debian/control
    - set priority to 'optional' to match override file
    - b-d on python instead of python-dev, since building an arch:all package

 -- Sandro Tosi <morph@debian.org>  Tue, 02 Mar 2010 13:21:30 +0100

pydoctor (0.2-4) unstable; urgency=low

  * change section to extra since nevow is in extra

 -- Guido Guenther <agx@sigxcpu.org>  Wed, 21 Nov 2007 19:50:09 +0100

pydoctor (0.2-3) unstable; urgency=low

  * add maintainer name

 -- Guido Guenther <agx@sigxcpu.org>  Sun, 19 Aug 2007 14:04:13 +0200

pydoctor (0.2-2) unstable; urgency=low

  * first upload to unstable (Closes: #435847)
  * set calendarserver-maintainers as maintainers
  * no need for quilt at the moment

 -- Guido Guenther <agx@sigxcpu.org>  Fri, 03 Aug 2007 17:30:41 +0200

pydoctor (0.2-1) calendarserver; urgency=low

  * New Upstream Version

 -- Guido Guenther <agx@sigxcpu.org>  Fri, 29 Sep 2006 19:04:01 +0200

pydoctor (0.0.svn31879-1) calendarserver; urgency=low

  * Initial release.

 -- Guido Guenther <agx@sigxcpu.org>  Thu, 28 Sep 2006 19:07:50 +0200