File: changelog

package info (click to toggle)
pyfai 0.20.0+dfsg1-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 78,460 kB
  • sloc: python: 49,743; lisp: 7,059; sh: 225; ansic: 165; makefile: 119
file content (371 lines) | stat: -rw-r--r-- 11,768 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
pyfai (0.20.0+dfsg1-3) unstable; urgency=medium

  * Added upstream patch to fix i386 FTBFS
  * Bug fix: "FTBFS on 32 bit archs: OverflowError: Python int too large
    to convert to C ssize_t", thanks to Sebastian Ramacher (Closes:
    #981494).
  * Bug fix: "pyfai fails tests with Python 3.8", thanks to Matthias Klose
    (Closes: #945411).

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Tue, 02 Feb 2021 10:27:14 +0100

pyfai (0.20.0+dfsg1-2) unstable; urgency=medium

  * d/p/0005-upstream-fix-for-32bits-patforms.patch

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Mon, 01 Feb 2021 14:27:26 +0100

pyfai (0.20.0+dfsg1-1) unstable; urgency=medium

  * fixed build option name nodocs -> nodoc
  * New upstream version 0.20.0+dfsg1
  * d/control: Added Build-Depends-Indep python3-sphinx-rtd-theme
  * d/t/control: Marked all tests skip-not-installable since pyopencl is
    not available on all architectures.

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 29 Jan 2021 14:42:23 +0100

pyfai (0.19.0+dfsg1-3) unstable; urgency=medium

  * d/t/control: less verbosity for now

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 29 Feb 2020 12:08:19 +0100

pyfai (0.19.0+dfsg1-2) unstable; urgency=medium

  * d/t/control: Added the missing python3-tk and python3-tk-dbg.

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Wed, 26 Feb 2020 14:55:28 +0100

pyfai (0.19.0+dfsg1-1) unstable; urgency=medium

  [ Steffen Möller ]
  * Add new file with ref to conda

  [ Picca Frédéric-Emmanuel ]
  * New upstream version 0.19.0+dfsg1
  * d/control: Used dh-sequence-python3.
  * d/patches: Refreshed

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 01 Feb 2020 15:35:39 +0100

pyfai (0.18.0+dfsg1-3) unstable; urgency=medium

  * Team upload.
  * keep python3-sphinx in general Build-Depends.
    Required to define dh sphinxdoc addon.

 -- Drew Parsons <dparsons@debian.org>  Sun, 22 Sep 2019 10:03:42 +0800

pyfai (0.18.0+dfsg1-2) unstable; urgency=medium

  * Team upload.
  * only build docs for arch-indep builds
  * mark python-pyfai-doc as Multi-Arch: foreign

 -- Drew Parsons <dparsons@debian.org>  Sun, 22 Sep 2019 02:57:00 +0800

pyfai (0.18.0+dfsg1-1) unstable; urgency=medium

  * Team upload.

  [ Picca Frédéric-Emmanuel ]
  * Use debhelper-compat instead of debian/compat.

  [ Sandro Tosi ]
  * Drop python 2 support; Closes: #937436
  * debian/control
    - bump Standards-Version to 4.4.0 (no changes needed)
  * debian/rules
    - add debug symbols to the -dbg package

  [ Drew Parsons ]
  * add debian patch test_split_bbox_2d-fix_zero_test.patch to test
    zero within machine precision in test_split_bbox_2d
    (cf. upstream issue #1111)
  * debhelper compatibility level 12

 -- Drew Parsons <dparsons@debian.org>  Sat, 21 Sep 2019 17:48:55 +0800

pyfai (0.18.0+dfsg1-1~exp1) experimental; urgency=medium

  * New upstream version 0.18.0+dfsg1
  * d/control
    - Build-Depends on python[3]-silx[-dbg] >= 0.10.1
    - Bumped Standards-Version 4.3.0 (nothing to do)
    - Switched to compat level 11
  * d/patches
    - Refreshed

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Tue, 28 May 2019 11:26:33 +0200

pyfai (0.17.0+dfsg1-3) unstable; urgency=medium

  [ Alexandre Marie ]
  * d/t/control Changed the command line that run the tests.

 -- Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>  Thu, 10 Jan 2019 10:35:17 +0100

pyfai (0.17.0+dfsg1-2) unstable; urgency=medium

  * d/p/0004-Skipped-unittests-for-i386-arch.patch (Closes: #916292).
  * d/rules: Build doc only with python3.
  * d/p/0005-Hid-fvisibility-and-D.patch: Fixed FTBFS on unstable.

 -- Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>  Mon, 07 Jan 2019 16:25:17 +0100

pyfai (0.17.0+dfsg1-1) unstable; urgency=medium

  [ Picca Frédéric-Emmanuel ]
  * d/t/control.dep8 -> d/t/control pyfai export the pyFAI module and not
    pyfai as expected by autodep8.
  * Switched pyfai scripts to python3
  * d/control: Removed useless pymca5 dependencies.
  * d/rules: do not run QT tests

  [ Alexandre Marie ]
  * New upstream version 0.17.0+dfsg1

 -- Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>  Thu, 20 Dec 2018 12:06:10 +0100

pyfai (0.16.0+dfsg1-2) unstable; urgency=medium

  * Exported XDG_CACHE_DIR to store openCL kernels and
    fixed the FTBFS.

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sun, 28 Oct 2018 22:07:52 +0100

pyfai (0.16.0+dfsg1-1) unstable; urgency=medium

  [ Picca Frédéric-Emmanuel ]
  * New upstream version 0.16.0+dfsg1
  * d/control
    - Removed useless XS-Python[3]
    - Removed useless Testsuite
    - Fixed URL for salsa
    - Bump Standrad-Version 4.2.1 (nothing to do)
    - Build-Depends
      + Added python[3]-silx[-dbg] (>= 0.8.0)
  * d/test
    - Moves all tests into control.autodep8

  [ Salsa Pipeline Bot ]
  * Add pipeline template
  * Initial pipeline

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sun, 28 Oct 2018 13:58:42 +0100

pyfai (0.15.0+dfsg1-1) unstable; urgency=medium

  * New upstream version 0.15.0+dfsg1
  * Repacked to deal the new third_party layout (Closes: #889183)
  * d/control
    - Build-Depends:
      - Added pandoc
      - Added python[3]-nbsphinx
  * d/patches
    + 0005-unactive-script-test.patch (Added)
  * d/rules
    - Do not build the documentation with python2-dbg

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 03 Feb 2018 09:08:32 +0100

pyfai (0.15.0+dfsg-1) unstable; urgency=medium

  * New upstream version 0.15.0+dfsg
  * d/control
    - Bump Standrad-Version 4.1.3 (nothing)
  * debian/patches
    - refreshed
  * d/watch
    - _src is optional

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 02 Feb 2018 22:05:05 +0100

pyfai (0.14.2+dfsg-6) unstable; urgency=medium

  * fix for real the ftbfs

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 01 Dec 2017 18:17:32 +0100

pyfai (0.14.2+dfsg-5) unstable; urgency=medium

  * d/rules
    - Fixed the FTBFS by providing the POCL cache dir (Closes: #876739)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 01 Dec 2017 17:08:59 +0100

pyfai (0.14.2+dfsg-4) unstable; urgency=medium

  * d/patches
    - 0004-instrument-setup-code-to-deal-with-the-buildd-FTBFS.patch (Updated)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 01 Dec 2017 14:58:36 +0100

pyfai (0.14.2+dfsg-3) unstable; urgency=medium

  * d/patches
    - 0004-instrument-setup-code-to-deal-with-the-buildd-FTBFS.patch (Added)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 01 Dec 2017 13:37:21 +0100

pyfai (0.14.2+dfsg-2) unstable; urgency=medium

  * d/control
    - Bump Standrad-Version 4.1.1 (nothing)
    - Fixed broken dependency python3-pymca-dbg -> python3-pymca5-dbg
    - Added python-numpy-dbg, python3-numpy-dbg

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Mon, 16 Oct 2017 14:37:48 +0200

pyfai (0.14.2+dfsg-1) unstable; urgency=medium

  * New upstream version 0.14.0+dfsg
  * debian/watch
    - Check the pgp signature via uscan
  * debian/upstream
    - add the upstream keyring
  * debian/control
    - Bump Standrad-Version 4.0.1 (extra -> optional)
    - Build-Depends
      + Fixed with cme
      + Removed python[3]-pil[-dbg]
      + Removed python[3]-lxml[-dbg]
      + Added python[3]-numexpr[-dbg]
      + Added python[3]-pymca5[-dbg]
      + Added python[3]-pyopencl[-dbg]
      + Added help2man in order to generate the manpages.
      + Added xauth, xvfb
  * debian/patches
    - 0003-remove-a-wrong-PYTHONPATH-modification.patch  (Added)
    - 0003-use-the-system-mathjax.patch (Added)
    - 0005-fix-the-setup-dependencies.patch (Added)
  * Debian/rules
    - Run tests with xvfb

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Mon, 31 Jul 2017 13:40:50 +0200

pyfai (0.13.0+dfsg-1) unstable; urgency=medium

  * New upstream version 0.13.0+dfsg

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 03 Dec 2016 10:00:18 +0100

pyfai (0.12.0+dfsg-5) unstable; urgency=medium

  * Remove python-fftw dependency

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 27 Aug 2016 16:59:18 +0200

pyfai (0.12.0+dfsg-4) unstable; urgency=medium

  * debian/tests/control
    - * Add python-tk-dbg and python3-tk-dbg Depends

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Thu, 18 Aug 2016 20:57:26 +0200

pyfai (0.12.0+dfsg-3) unstable; urgency=medium

  * debian/tests/control
    - Add pyfai dependency for all tests

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Thu, 18 Aug 2016 09:19:00 +0200

pyfai (0.12.0+dfsg-2) unstable; urgency=medium

  * New Homepage https://github.com/silx-kit/pyFAI
  * debian/control
    - Build-Depends on python3-fabio-x (>= 0.4.0+dfsg-2~)
    - Updated Vcs-x in order to use https
  * debian/patchs
    - 0004-do-not-use-deprecated-sphinx-pngmath-extension.patch (new)
      In order to fix an FTBFS (closes: #831242)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Wed, 17 Aug 2016 13:03:44 +0200

pyfai (0.12.0+dfsg-1) unstable; urgency=medium

  * Imported Upstream version 0.12.0+dfsg
  * Updated Files-Excluded to remove the pre-generated documentation.
  * debian/patchs
    - 0001-fix-pyFAI-when-third_party-is-missing.patch (upstreamed)
    - 0002-fix-from-upstream-python3-installation.patch (upstreamed)
    - 0003-fix-from-upstream-for-fabio-3.x.patch (upstreamed)
    + 0001-remove-useless-logic-in-conf.py.patch (new)
    + 0002-skip-test-if-no-network.patch (new)
    + 0003-use-the-system-mathjax.patch (new)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Tue, 07 Jun 2016 14:50:00 +0200

pyfai (0.11.0+dfsg-5) unstable; urgency=medium

  * debian/patch
    + 0003-fix-from-upstream-for-fabio-3.x.patch (updated)
      previous patch was wrong.

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sun, 27 Mar 2016 15:51:21 +0200

pyfai (0.11.0+dfsg-4) unstable; urgency=medium

  * debian/control
    - Added Build-Depends fabio (>= 0.3.0+dfsg-1~)
  * debian/patch
    + 0003-fix-from-upstream-for-fabio-3.x.patch

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Sat, 26 Mar 2016 15:25:53 +0100

pyfai (0.11.0+dfsg-3) unstable; urgency=medium

  * debian/path
    + 0002-fix-from-upstream-python3-installation.patch (Closes: #794221)

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 11 Sep 2015 14:25:10 +0200

pyfai (0.11.0+dfsg-2) unstable; urgency=medium

  * Split pyfai package to follow the Debian modules name policy.
  * Added python-pyfai, python-pyfai-dbg, python3-pyfai,
    python3-pyfai-dbg, python-pyfai-doc

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Mon, 27 Jul 2015 16:18:27 +0200

pyfai (0.11.0+dfsg-1) unstable; urgency=medium

  * Imported Upstream version 0.11.0+dfsg
  * debian/control
    - Added Build-Depends fabio (>= 0.2.2+dfsg~)
  * debian/watch
    - use the pypi redirector
  * debian/copyright
    - use Files-Exclude to repack sources
  * debian/patches
    + 0001-fix-pyFAI-when-third_party-is-missing.patch

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 24 Jul 2015 10:57:04 +0200

pyfai (0.10.2-2~exp1) experimental; urgency=medium

  * switch to dh-python

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 02 Jan 2015 15:13:07 +0100

pyfai (0.10.2-1) unstable; urgency=medium

  * Import new upstream version (0.10.2)
  * debian/control
    - Bump Standrad-Version 3.9.6 (nothing to do)
    - fix Build-Depends/Depends with cme
    - prepare for Debian-Science team maintenance.
  * debian/copyright
    - use copyright-format/1.0
  * debian/rules
    - cythonize files during the build
    - use dh_numpy for better binary dependency.

 -- Picca Frédéric-Emmanuel <picca@debian.org>  Fri, 24 Oct 2014 09:01:53 +0100

pyfai (0.3.5-1) unstable; urgency=low

  * Initial release (Closes: #656633)

 -- Jerome Kieffer <jerome.kieffer@esrf.fr>  Fri, 20 Jan 2012 22:00:20 +0100