1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
|
build3vers := $(shell py3versions -sv)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ --with python3
override_dh_auto_build:
set -e && for i in $(build3vers); do \
python$$i setup.py build; \
done
override_dh_auto_install:
set -e && for i in $(build3vers); do \
python$$i setup.py install --install-layout=deb --root $(CURDIR)/debian/python3-pykcs11; \
done
override_dh_auto_clean:
python3 setup.py clean
|