File: changelog

package info (click to toggle)
pymarkups 3.1.1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 252 kB
  • sloc: python: 865; sh: 7; makefile: 3
file content (179 lines) | stat: -rw-r--r-- 5,732 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
pymarkups (3.1.1-1) unstable; urgency=medium

  * New upstream release.
  * Add a patch to make the doctest pass with recent changes.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 05 Mar 2021 19:59:50 +0300

pymarkups (3.1.0-1) unstable; urgency=medium

  [ Debian Janitor ]
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.

  [ Ondřej Nový ]
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Sandro Tosi ]
  * Use the new Debian Python Team contact name and address

  [ Dmitry Shachnev ]
  * New upstream release.
  * Update my key in debian/upstream/signing-key.asc.
  * Add python3-yaml to Build-Depends, Recommends and test depends.
  * Remove no longer needed dependency on python3-pkg-resources.
  * Add python3-pygments to Build-Depends.
  * Update to debhelper compat level 13.
  * Bump Standards-Version to 4.5.1, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 31 Jan 2021 22:02:14 +0300

pymarkups (3.0.0-2) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * Make the autopkgtest depend on python3-pygments.
  * Make the autopkgtest depend on python3-all, and use py3versions -s
    instead of -i.
  * Update to debhelper compat level 12.
  * Bump Standards-Version to 4.5.0, no changes needed.

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 20 Mar 2020 14:57:39 +0300

pymarkups (3.0.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field
  * d/watch: Use https protocol
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
  * d/control: Remove ancient X-Python3-Version field

  [ Dmitry Shachnev ]
  * New upstream release.
  * Add build-dependencies on python3-mdx-math and python3-setuptools.
  * Bump Breaks on retext to (<< 6.0~).
  * Update copyright years in debian/copyright.
  * Update debhelper compat level to 11.
  * Add runtime dependency on python3-pkg-resources.
  * Add Markups.egg-info/ to pybuild.testfiles to make the tests pass.
  * Bump Standards-Version to 4.1.5, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 06 Jul 2018 15:26:04 +0300

pymarkups (2.0.1-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Bump Standards-Version to 4.0.0, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 29 Jun 2017 16:06:03 +0300

pymarkups (2.0.0-1) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * Add Breaks on old versions of ReText (less than 5.1).
  * New upstream release.
  * Bump Standards-Version to 3.9.8, no changes needed.
  * Bump year in debian/copyright.

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 14 May 2016 19:17:47 +0300

pymarkups (1.0.1-1) unstable; urgency=medium

  * New upstream release.
  * Add python3-textile to build-dependencies, test dependencies, and
    the Recommends: list for python3-markups, now that it's available.
  * Remove obsolete debian/python3-markups.examples file.

 -- Dmitry Shachnev <mitya57@debian.org>  Tue, 22 Dec 2015 17:43:19 +0300

pymarkups (1.0.0-1) unstable; urgency=medium

  * New upstream release.
  * Update Homepage URL.
  * Update package description.
  * Drop custom dh_auto_test override, let pybuild do the right thing.
  * Bump X-Python3-Version to 3.2, following upstream.
  * Add an autopkgtest.
  * Update Vcs fields for Git migration.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 13 Dec 2015 22:12:45 +0300

pymarkups (0.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Require python3-markdown 2.6, the mathjax extension does not work
    with older versions.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 20 Jun 2015 20:10:57 +0300

pymarkups (0.6.1-1) unstable; urgency=medium

  * Upload to unstable.
  * New upstream release.
  * Update debian/watch to use pypi.debian.net redirector.
  * Add my key to debian/upstream/signing-key.asc and make uscan verify
    the signature.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 19 Apr 2015 12:17:05 +0300

pymarkups (0.6.0-1) experimental; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.6, no changes needed.
  * Bump copyright year in debian/copyright.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 25 Jan 2015 20:00:24 +0300

pymarkups (0.5.2-1) unstable; urgency=medium

  * New upstream bugfix release.
    - Fixes loading of Markdown extensions with modules (closes: #768179).

 -- Dmitry Shachnev <mitya57@debian.org>  Wed, 05 Nov 2014 21:07:10 +0300

pymarkups (0.5.1-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Explicitly build-depend on dh-python.
  * Update my e-mail address.

 -- Dmitry Shachnev <mitya57@debian.org>  Tue, 16 Sep 2014 10:22:49 +0400

pymarkups (0.5.0-1) unstable; urgency=medium

  * New upstream release.
  * Update URLs for upstream move from Launchpad to GitHub.
  * Convert to pybuild.
  * Bump Standards-Version to 3.9.5, no changes needed.

 -- Dmitry Shachnev <mitya57@gmail.com>  Fri, 25 Jul 2014 22:51:18 +0400

pymarkups (0.4-1) unstable; urgency=low

  * New upstream release.
  * debian/watch: use HTTPS, and correctly escape dots.

 -- Dmitry Shachnev <mitya57@gmail.com>  Sat, 30 Nov 2013 13:27:43 +0400

pymarkups (0.3-1) unstable; urgency=low

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Dmitry Shachnev ]
  * New upstream release.

 -- Dmitry Shachnev <mitya57@gmail.com>  Thu, 25 Jul 2013 14:30:31 +0400

pymarkups (0.2.4-1) unstable; urgency=low

  * Initial release (Closes: #687824).

 -- Dmitry Shachnev <mitya57@gmail.com>  Sun, 25 Nov 2012 18:13:08 +0400