1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
DEB_PYTHON_SUPPORT?=python2
PYVERS = $(shell pyversions -r -v)
%:
dh $@ --with $(DEB_PYTHON_SUPPORT)
override_dh_auto_build:
dh_auto_build
$(MAKE) -C doc html
override_dh_auto_clean:
dh_auto_clean
$(MAKE) -C doc clean
override_dh_installdocs:
dh_installdocs -X.buildinfo
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
set -e -x; \
cd tests; \
for py in $(PYVERS); do \
PYTHONPATH=$$( echo $(CURDIR)/build/lib.*-$$py ) python$$py all_tests.py ; \
done
endif
override_dh_compress:
dh_compress -X.js
|