1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143
|
Source: pyopencl
Section: python
Priority: optional
Maintainer: Debian OpenCL Maintainers <pkg-opencl-devel@lists.alioth.debian.org>
Uploaders:
Tomasz Rybak <serpent@debian.org>,
Andreas Beckmann <anbe@debian.org>,
Build-Depends:
debhelper-compat (= 13),
dh-sequence-numpy3,
dh-sequence-python3,
mesa-common-dev,
ocl-icd-opencl-dev | opencl-dev,
opencl-c-headers,
pocl-opencl-icd,
pybind11-dev,
python3-all-dbg,
python3-all-dev,
python3-mako,
python3-numpy,
python3-pybind11 (>= 2.5.0),
python3-pytest <!nocheck>,
python3-pytools (>= 2017.6),
python3-setuptools,
Build-Depends-Indep:
dh-sequence-sphinxdoc <!nodoc>,
python-mako-doc <!nodoc>,
python-numpy-doc <!nodoc>,
python3-doc <!nodoc>,
python3-sphinx (>= 1.0.7+dfsg) <!nodoc>,
python3-sphinx-copybutton <!nodoc>,
Standards-Version: 4.5.1
Rules-Requires-Root: no
Homepage: https://mathema.tician.de/software/pyopencl
Vcs-Git: https://salsa.debian.org/opencl-team/python-pyopencl.git
Vcs-Browser: https://salsa.debian.org/opencl-team/python-pyopencl
Package: python3-pyopencl
Architecture: any
Multi-Arch: no
Depends:
ocl-icd-libopencl1 | libopencl1,
pocl-opencl-icd | opencl-icd,
python3-appdirs (>= 1.4.0),
python3-mako,
python3-numpy,
python3-pkg-resources,
python3-pytools (>= 2017.6),
python3-six,
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
Recommends:
python-pyopencl-doc <!nodoc>,
Suggests:
python3-imaging-tk,
python3-matplotlib,
python3-opengl,
python3-pyopencl-dbg,
python3-pytest,
Description: Python 3 module to access OpenCL parallel computation API
PyOpenCL lets you access the OpenCL parallel computation API from
Python. Here's what sets PyOpenCL apart:
* Object cleanup tied to lifetime of objects. This idiom, often called
RAII in C++, makes it much easier to write correct, leak- and
crash-free code.
* Completeness. PyOpenCL puts the full power of OpenCL’s API at your
disposal, if you wish.
* Convenience. While PyOpenCL's primary focus is to make all of OpenCL
accessible, it tries hard to make your life less complicated as it
does so--without taking any shortcuts.
* Automatic Error Checking. All OpenCL errors are automatically
translated into Python exceptions.
* Speed. PyOpenCL’s base layer is written in C++, so all the niceties
above are virtually free.
* Helpful, complete documentation and a wiki.
* Liberal licensing (MIT).
.
This package contains Python 3 modules.
Package: python3-pyopencl-dbg
Section: debug
Architecture: any
Multi-Arch: no
Depends:
python3-dbg,
python3-pyopencl (= ${binary:Version}),
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
Description: Python 3 module to access OpenCL API (debug extensions)
PyOpenCL lets you access the OpenCL parallel computation API from
Python. Here's what sets PyOpenCL apart:
* Object cleanup tied to lifetime of objects. This idiom, often called
RAII in C++, makes it much easier to write correct, leak- and
crash-free code.
* Completeness. PyOpenCL puts the full power of OpenCL’s API at your
disposal, if you wish.
* Convenience. While PyOpenCL's primary focus is to make all of OpenCL
accessible, it tries hard to make your life less complicated as it
does so--without taking any shortcuts.
* Automatic Error Checking. All OpenCL errors are automatically
translated into Python exceptions.
* Speed. PyOpenCL’s base layer is written in C++, so all the niceties
above are virtually free.
* Helpful, complete documentation and a wiki.
* Liberal licensing (MIT).
.
This package contains extensions build for the Python 3 debug interpreter.
Package: python-pyopencl-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Build-Profiles: <!nodoc>
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Recommends:
python-mako-doc,
python-numpy-doc,
python3-doc,
Suggests:
python3-pyopencl,
Description: module to access OpenCL parallel computation API (documentation)
PyOpenCL lets you access the OpenCL parallel computation API from
Python. Here's what sets PyOpenCL apart:
* Object cleanup tied to lifetime of objects. This idiom, often called
RAII in C++, makes it much easier to write correct, leak- and
crash-free code.
* Completeness. PyOpenCL puts the full power of OpenCL’s API at your
disposal, if you wish.
* Convenience. While PyOpenCL's primary focus is to make all of OpenCL
accessible, it tries hard to make your life less complicated as it
does so--without taking any shortcuts.
* Automatic Error Checking. All OpenCL errors are automatically
translated into Python exceptions.
* Speed. PyOpenCL’s base layer is written in C++, so all the niceties
above are virtually free.
* Helpful, complete documentation and a wiki.
* Liberal licensing (MIT).
.
This package contains HTML documentation and example scripts.
|