1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
export PYBUILD_NAME=pyosmium
%:
dh $@ \
--buildsystem pybuild \
--with python2,python3 \
--parallel
override_dh_clean:
dh_clean
$(RM) -r doc/_build
override_dh_auto_build-indep:
dh_auto_build --indep
(cd doc && PYTHONPATH=$(CURDIR)/.pybuild/pythonX.Y_`py3versions -vd`/build make html)
override_dh_auto_test:
PYBUILD_SYSTEM=custom \
PYBUILD_TEST_ARGS="cd test && {interpreter} run_tests.py" dh_auto_test
override_dh_install:
dh_install
$(RM) debian/*/usr/share/doc/*/html/_static/jquery.js
$(RM) debian/*/usr/share/doc/*/html/_static/underscore.js
|