1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106
|
PYTHON=$(shell command -v pypy > /dev/null && echo pypy || echo python2.7)
BUILDFLAGS_ENV := DEB_BUILD_MAINT_OPTIONS=hardening=-stackprotector,-fortify
BUILDFLAGS_ENV += DEB_CFLAGS_MAINT_STRIP="-O0 -O1 -O2 -O3 -Os -Ofast -g"
export CFLAGS = $(shell $(BUILDFLAGS_ENV) dpkg-buildflags --get CFLAGS)
export LDFLAGS = $(shell $(BUILDFLAGS_ENV) dpkg-buildflags --get LDFLAGS)
include /usr/share/dpkg/architecture.mk
%:
dh $@ --with sphinxdoc
override_dh_auto_configure:
override_dh_auto_build-arch: pypy/goal/pypy-c
$(MAKE) -C pypy/doc man BUILDDIR=$(CURDIR)/build-docs
pypy/goal/pypy-c lib_pypy/pypy_tools/build_cffi_imports.py
debian/scripts/multiarch-extensions.sh
override_dh_auto_build-indep:
$(MAKE) -C pypy/doc html BUILDDIR=$(CURDIR)/build-docs
pypy/goal/pypy-c:
debian/scripts/translate.sh --python $(PYTHON)
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
override_dh_auto_test-arch: export TMPDIR = $(CURDIR)/build-tests-tmp
override_dh_auto_test-arch: export HOME = $(TMPDIR)
override_dh_auto_test-arch:
rm -rf $(TMPDIR) build-tests
mkdir $(TMPDIR) build-tests
PYTHONPATH=. $(PYTHON) -u testrunner/runner.py \
--logfile=build-tests/pytest-A.log \
--config=pypy/pytest-A.cfg \
--root=pypy || true
TERM=$${TERM:-dumb} $(PYTHON) -u pypy/test_all.py \
--pypy=pypy/goal/pypy-c \
--resultlog=build-tests/lib-python.log \
lib-python || true
pypy/goal/pypy-c -u pypy/test_all.py \
--resultlog=build-tests/pypy-c.log \
pypy/module/pypyjit/test_pypy_c || true
endif
override_dh_auto_install:
debian/scripts/gen-backend-versions.py
override_dh_fixperms-arch:
debian/scripts/cleanup-lib.sh pypy-lib
find debian/pypy-tk \( -name '*.pyc' -o -name '__pycache__' \) -delete
find debian/pypy-tk \
-name '*.py' -print0 \
| xargs -0 sed -i -e '1s|^
dh_fixperms -a
override_dh_fixperms-indep:
debian/scripts/cleanup-lib.sh pypy-lib-testsuite
dh_fixperms -i
override_dh_sphinxdoc-arch:
override_dh_compress:
dh_compress -X.inv -X.txt
override_dh_shlibdeps-arch:
dh_shlibdeps --package=pypy -- -dPre-Depends
dh_shlibdeps --arch --remaining-packages
override_dh_installdeb:
set -e; for maintscript in preinst postinst prerm; do \
sed -e 's/
-e 's/
debian/pypy.$$maintscript.in > debian/pypy.$$maintscript; \
done
dh_installdeb
HG_REPO ?= https://bitbucket.org/pypy/pypy
REV=$(shell dpkg-parsechangelog | sed -rne 's,^Version: .*hg([0-9]+).*,\1,p')
VER=$(shell dpkg-parsechangelog | sed -rne 's,^Version: (.+)\+dfsg-.*,\1,p' | sed -e 's/~//')
get-packaged-orig-source:
@echo "You can build this from a local repo by supplying the HG_REPO variable"
rm -rf pypy-$(VER).orig
hg clone $(HG_REPO) pypy-$(VER).orig
ifeq (,$(REV))
cd pypy-$(VER).orig && hg up -r release-pypy2.7-v$(VER)
else
cd pypy-$(VER).orig && hg up -r $(REV)
endif
rm -rf pypy-$(VER).orig/.hg*
rm pypy-$(VER).orig/lib-python/2.7/distutils/command/*.exe
rm pypy-$(VER).orig/rpython/rlib/test/loadtest/loadtest*.dll
rm -rf pypy-$(VER).orig/lib-python/2.7/ensurepip/_bundled/
tar -cJ --owner root --group root --mode a+rX \
-f pypy_$(VER)+dfsg.orig.tar.xz pypy-$(VER).orig
rm -rf pypy-$(VER).orig
|