File: changelog

package info (click to toggle)
pyqt5chart 5.15.4%2Bdfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, sid
  • size: 456 kB
  • sloc: python: 1,232; makefile: 20; sh: 11
file content (120 lines) | stat: -rw-r--r-- 3,839 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
pyqt5chart (5.15.4+dfsg-2) unstable; urgency=medium

  * Team upload.
  * Pass correct --target-dir to sip-build, to fix FTBFS with sip ≥ 6.2.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 23 Oct 2021 15:13:12 +0300

pyqt5chart (5.15.4+dfsg-1) unstable; urgency=medium

  * Team upload.

  [ Debian Janitor ]
  * Bump debhelper from old 12 to 13.
  * Set field Upstream-Name in debian/copyright.

  [ Dmitry Shachnev ]
  * New upstream release.
  * Bump years in debian/copyright.
  * Bump python3-pyqtbuild build-dependency to 1.9, per pyproject.toml.
  * Bump runtime PyQt5 dependencies to 5.15.4, per pyproject.toml.
  * Stop building extensions for Python debug interpreter (closes: #994336).
    - Rely on automatic dbgsym packages for debug symbols.
  * Bump Standards-Version to 4.6.0, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Wed, 15 Sep 2021 17:47:53 +0300

pyqt5chart (5.15.2+dfsg-2) unstable; urgency=medium

  * Team upload.
  * Build-depend on sip-tools instead of sip5-tools, in preparation for
    SIP v6.
  * Mark the autopkgtest as superficial.
  * Update Homepage URL.

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 28 Jan 2021 13:36:13 +0300

pyqt5chart (5.15.2+dfsg-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Bump required python3-pyqtbuild version to 1.6.
  * Bump Standards-Version to 4.5.1, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Mon, 30 Nov 2020 19:10:39 +0300

pyqt5chart (5.15.1+dfsg-1) unstable; urgency=medium

  * Team upload.

  [ Ondřej Nový ]
  * d/control: Update Maintainer field with new Debian Python Team
    contact address.
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Dmitry Shachnev ]
  * New upstream release.
  * Bump PyQt5 build- and run-time dependencies to 5.15.1.
  * Bump years in debian/copyright.
  * Upload to unstable.

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 24 Sep 2020 16:17:28 +0300

pyqt5chart (5.15.0+dfsg-1) experimental; urgency=medium

  * Team upload.

  [ Dmitry Shachnev ]
  * Drop python-all-dbg from autopkgtest dependencies (closes: #943218).
  * Update debian/watch to track releases from PyPI.
  * New upstream release.
  * Switch from sip4 to sip5.
  * Use dh sequencer and pybuild build system.
  * Drop Multi-Arch: same fields. Unfortunately PEP 3149 .abi3 tagged
    files do not have an architecture marker.
  * Remove custom LDFLAGS: -Wl,-O1 is added by qmake and -Wl,--as-needed
    is default in Bullseye.
  * Use ${python3:Depends} for python3-pyqt5.qtchart-dbg.

  [ Debian Janitor ]
  * Drop unnecessary dh arguments: --parallel, --parallel
  * Rely on pre-initialized dpkg-architecture variables.
  * Update standards version to 4.5.0, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 20 Jun 2020 14:03:12 +0300

pyqt5chart (5.11.3+dfsg-2) unstable; urgency=medium

  * Team Upload

  [ Emmanuel Arias ]
  * Apply Matthias Klose’s patch to fix include directories
    for Python 3.8 (Closes: #942748)
  * d/control: Bump Standards-Version to 4.4.1
  * d/control: Use debhelper-compat instead of debhelper.
    - Bump debhelper to 12

  [ Jonathan Carter ]
  * Upload to unstable

 -- Emmanuel Arias <emmanuelarias30@gmail.com>  Mon, 21 Oct 2019 00:11:15 -0300

pyqt5chart (5.11.3+dfsg-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/watch: Use https protocol

  [ Stephen Kitt ]
  * New upstream release.
  * Set “Rules-Requires-Root: no”.
  * Standards-Version 4.2.1, no further change required.
  * Allow co-installation of the various Python library packages.

 -- Stephen Kitt <skitt@debian.org>  Wed, 12 Dec 2018 22:39:38 +0100

pyqt5chart (5.10.1+dfsg-1) unstable; urgency=medium

  * Initial release. Closes: #892198.

 -- Stephen Kitt <skitt@debian.org>  Thu, 07 Jun 2018 22:46:29 +0200