File: changelog

package info (click to toggle)
pyqwt3d 0.1.8-6
  • links: PTS, VCS
  • area: main
  • in suites:
  • size: 984 kB
  • sloc: python: 3,932; cpp: 328; makefile: 115; sh: 7
file content (237 lines) | stat: -rw-r--r-- 7,886 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
pyqwt3d (0.1.8-6) unstable; urgency=medium

  [ Stefano Rivera ]
  * Team upload.
  * d/control: Update Uploader field with new Debian Python Team contact
    address.
  * Add --sip-include-dirs parameter to configure. Has changed in pyqt5-dev since
    5.15.0+dfsg-2. (Closes: #971185)

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.
  * Bump Standards-Version to 4.4.1.
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Debian Janitor ]
  * Apply multi-arch hints.
    + python-qwt3d-doc: Add Multi-Arch: foreign.

 -- Stefano Rivera <stefanor@debian.org>  Fri, 16 Oct 2020 22:11:02 -0700

pyqwt3d (0.1.8-5) unstable; urgency=medium

  * Add patch for fixing FTBFS with sip >= 4.19.14 (Closes: #924733)

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Mon, 18 Mar 2019 06:55:14 +0100

pyqwt3d (0.1.8-4) unstable; urgency=medium

  * Add -Wno-narrowing to OpenGL makefile, fixes FTBFS.
    Thanks to Christian Seiler (Closes: #918680)

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Wed, 09 Jan 2019 06:55:28 +0100

pyqwt3d (0.1.8-3) unstable; urgency=medium

  * Remove hardcoding of qt_inc_dir with 01_configure patch,
    fixes FTBFS (Closes: #916293)
  * Bump standards version to 4.3.0, no changes needed

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Mon, 07 Jan 2019 13:42:59 +0100

pyqwt3d (0.1.8-2) unstable; urgency=medium

  * Add support for all python3 versions
  * Add conflicts/replaces obsolete python-qwt3d-qt4
  * Fix watch file

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Tue, 16 Oct 2018 21:09:55 +0200

pyqwt3d (0.1.8-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)
  * d/control: Set Vcs-* to salsa.debian.org
  * d/rules: Remove trailing whitespaces
  * d/control: Remove ancient X-Python-Version field
  * Convert git repository from git-dpm to gbp layout

  [ Gudjon I. Gudjonsson ]
  * New upstream source (Closes: #812138)
  * Bump standards version to 4.2.1
  * Add python3-qwt3d-qt5 package
  * Bump compat to 11
  * Remove Qt4/python2 version (Closes: #699032, #875116)
  * Add Qt5/python3 version
  * Remove get-orig-source from rules
  * Update watch file to point to new upstream
  * Add dependencies on qt5 and pyqt5 packages

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Fri, 14 Sep 2018 22:04:21 +0200

pyqwt3d (0.1.7~cvs20090625-13) unstable; urgency=medium

  * Update patch 04_fix_sip4.10.patch to fix compilation (Closes: #751057)
  * Bump standards version to 3.9.5, no changes

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Mon, 30 Jun 2014 07:51:06 +0000

pyqwt3d (0.1.7~cvs20090625-12) unstable; urgency=medium

  * Binary rebuild, no change. Fixes segmentation fault.

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Thu, 02 Jan 2014 17:42:23 +0100

pyqwt3d (0.1.7~cvs20090625-11) unstable; urgency=low

  * Removing -lz from configure and zlib1g-dev dependency
  * Removing -lGLU from configure (Closes: #676500)
  * Bump standards version to 3.9.4
  * Add binary dependency on python-qwt5-qt4

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sat, 18 May 2013 22:18:47 +0200

pyqwt3d (0.1.7~cvs20090625-10) unstable; urgency=low

  * Team upload.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Scott Kitterman ]
  * Add missing build-depends on zlib1g-dev to fix FTBFS (Closes: #70879)

 -- Scott Kitterman <scott@kitterman.com>  Sat, 18 May 2013 15:51:17 -0400

pyqwt3d (0.1.7~cvs20090625-9) unstable; urgency=low

  [ Jakub Wilk ]
  * Add epoch to python-numpy version in Build-Depends.

  [ Gudjon I. Gudjonsson ]
  * Bump standards version to 3.9.3
  * Add -lGLU to configure.py command line

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sun, 13 May 2012 09:58:59 +0200

pyqwt3d (0.1.7~cvs20090625-8) unstable; urgency=low

  * Add dependency on python-numpy (Closes: #641795)
  * Add build-arch and indep targets

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Tue, 15 Nov 2011 06:51:06 +0100

pyqwt3d (0.1.7~cvs20090625-7) unstable; urgency=low

  * Switch to dh_python2 (Closes: #634863)
  * Bump standards version to 3.9.2
  * Upgraded dependencies
  * Add X-Python-Version
  * Change (C) to © in copyright file

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sun, 14 Aug 2011 20:21:54 +0200

pyqwt3d (0.1.7~cvs20090625-6) unstable; urgency=low

  * Remove dependency on python-qt-dev

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Fri, 25 Mar 2011 09:34:10 +0100

pyqwt3d (0.1.7~cvs20090625-5) unstable; urgency=low

  * Remove qt3 support (Closes: #604372)
  * Switch from dpatch to quilt. Rewrite all patches
  * Switch to dpkg-source 3.0 (quilt) format
  * Bump standards version to 3.9.1

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sat, 26 Feb 2011 22:12:06 +0100

pyqwt3d (0.1.7~cvs20090625-4) unstable; urgency=low

  * Fix sip version (Closes: #567227)
  * Bump standards version to 3.8.4
  * Add patch 04_fix_sip4.10 to fix compilation with sip4.10
  * Add misc depends to python-qwt3d-doc
  * Removed pyqt version fix

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sun, 07 Feb 2010 18:06:19 +0100

pyqwt3d (0.1.7~cvs20090625-3) unstable; urgency=low

  * Reubild in order to change binary dependencies from
    libqwtplot3d-qt{3,4} to libqwtplot3d-qt{3,4}-0
    according to name change in qwtplot3d package

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sun, 22 Nov 2009 23:57:36 +0100

pyqwt3d (0.1.7~cvs20090625-2) unstable; urgency=low

  * Change sip4 dependencies to >=4.9
  * Add binary dependency on python-sip4 >=4.9
  * Bump standards version to 3.8.3, no changes needed
  * Add README.source file

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sat, 07 Nov 2009 12:54:42 +0100

pyqwt3d (0.1.7~cvs20090625-1) unstable; urgency=low

  [ Gudjon I. Gudjonsson ]
  * New CVS version
    - Builds from source (Closes: #527662)
  * Add patch 03_fix_const_char
  * Upgrade build dependencies to sip4 (4.8.1)
  * Bump Standards-Version to 3.8.2 (no changes needed)
  * Hardcode DEB_UPSTREAM_VERSION, change in next release

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

  [ Bernd Zeimetz ]
  * Replace python-central by python-support to follow the change in
    python-qt4. This would not be an issue if python-central would
    create namespace packages properly. We should not need to
    change the build-dependency on python-qt4 as python-support should
    handle it for all versions in a sane way.
  * Depend on python-qtX-gl larger or equal than the version the package
    was built against.
  * Bump Standards-Version to 3.8.1, no changes needed.

  [ Piotr Ożarowski ]
  * Add get-orig-source rule
  * Prepare for Python 2.6: dh_install now recognizes files in
    /usr/local/*/dist-packages/ as well
  * Add preinst maintainer scipts in -qt3 and -qt4 packages

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Fri, 27 Jun 2009 16:18:13 +0200

pyqwt3d (0.1.6-2) unstable; urgency=medium

  [ Gudjon I. Gudjonsson ]
  * Add dependency on libqt4-opengl-dev (Closes: #482233)
  * Bump Standards-Version to 3.7.3 (no changes needed)

  [ Piotr Ożarowski ]
  * Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Wed, 28 May 2008 00:06:00 +0200

pyqwt3d (0.1.6-1) unstable; urgency=low

  * New upstream release
  * Needs libqwtplot3d (>=0.2.7+svn191) that includes patches from Gerard.
  * Added some minor notes to the copyright file.
  * Added a patch to fix ezplot.py and set its ownership to 644.
  * Homepage field added
  * Add python-qt{3,4}-gl to python-qwt3d-qt{3,4}'s Depends and python-numpy
    to Recommends
  * Build-depend on python-sip4-dev >= 4.7.1-1 (closes: #442971)

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Sun, 30 Sep 2007 12:47:35 +0200

pyqwt3d (0.1.4-1) unstable; urgency=low

  * Initial release (Closes: #413355)

 -- Gudjon I. Gudjonsson <gudjon@gudjon.org>  Thu, 14 Jun 2007 22:49:54 +0200