1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
|
include /usr/share/python/python.mk
PYTHON := /usr/bin/python
PYVERS := $(shell pyversions -vr debian/control)
PYVER := $(shell python -c 'import sys; print sys.version[:3]')
PYREXC=pyrexc
configure: configure-stamp
configure-stamp:
dh_testdir
touch configure-stamp
build-arch: build
build-indep: build
build: build-stamp
build-stamp: configure-stamp
find [DPTCs]* -type f -exec chmod -x {} \;
dh_testdir
touch build-stamp
clean: clean1st
clean1st:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
$(PYTHON) setup.py clean --all ;\
find . -name '*.pyc' -exec rm -rf {} \;
rm -f build-stamp
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(PYTHON) setup.py install --root=$(CURDIR)/debian/python-pyrex --no-compile $(py_setup_install_args)
for python in $(PYVERS); do \
sed 's/
chmod 755 debian/python-pyrex/usr/bin/python$$python-pyrexc ; \
done
dh_install -p pyrex-mode
binary-arch:
binary-indep: build install
dh_testdir
dh_testroot
dh_installdebconf
dh_installchangelogs CHANGES.txt
dh_installdocs
dh_installemacsen
dh_installexamples
dh_installman debian/pyrexc.1
for python in $(PYVERS); \
do dh_link -ppython-pyrex \
usr/share/man/man1/$(PYREXC).1.gz \
usr/share/man/man1/python$$python-$(PYREXC).1.gz ;\
done
dh_strip
dh_compress
dh_fixperms
dh_python2
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-arch binary-indep
.PHONY: build clean binary-indep binary-arch binary install configure clean1st
|