1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
|
export PYBUILD_NAME=arrayfire
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
PYTHONPATH=. http_proxy='127.0.0.1:9' \
sphinx-build -N -b html docs build/html
override_dh_auto_test:
PYBUILD_SYSTEM=custom \
PYBUILD_BEFORE_TEST="cp -r {dir}/tests {build_dir}" \
PYBUILD_TEST_ARGS="cd {build_dir}; {interpreter} -m tests" \
PYBUILD_AFTER_TEST="rm -rf {build_dir}/tests" \
dh_auto_test
override_dh_sphinxdoc:
dh_sphinxdoc --exclude=MathJax.js
|