1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
UPSTREAM_GIT := https://github.com/calmjs/calmjs.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=python_distutils --with python3
override_dh_auto_clean:
rm -rf build .stestr
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2 --in-tmp
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
echo "Unit tests not possible bacause of Py3 and namespaces."
endif
override_dh_auto_test:
echo "Do nothing..."
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
|