1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
export PYBUILD_NAME=changelogd
export PYBUILD_TEST_ARGS=--ignore=tests/test_entry_computed_values.py --ignore=tests/test_utils.py \
-k 'not test_full_flow \
and not test_partial_releases \
and not test_empty_release \
and not test_init_rst \
and not test_entry_help \
and not test_non_interactive_data[1] \
and not test_non_interactive_data[feature] \
and not test_multi_value_string \
and not test_entry_missing_message_types \
and not test_entry_incorrect_entry_fields \
and not test_user_data \
and not test_init_config \
and not test_release_same_version'
%:
dh $@ --with sphinxdoc --buildsystem=pybuild
override_dh_installdocs:
https_proxy='127.0.0.1:9' http_proxy='127.0.0.1:9' sphinx-build -b html docs build/sphinx/html
dh_installdocs -ppython-changelogd-doc --doc-main-package=python-changelogd-doc build/sphinx/html
dh_installdocs
|