1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
|
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=cheroot
export PYBUILD_SYSTEM=custom
export PYBUILD_CONFIGURE_ARGS=true
export PYBUILD_BUILD_ARGS=true
export PYBUILD_INSTALL_ARGS=mkdir -p {destdir}/usr/lib/python{version}/dist-packages && \
cp -r cheroot {destdir}/usr/lib/python{version}/dist-packages && \
sed -e 's/VERSION/$(DEB_VERSION_UPSTREAM:+ds=)/g' debian/cheroot.egg-info > \
{destdir}/usr/lib/python{version}/dist-packages/cheroot-$(DEB_VERSION_UPSTREAM:+ds=).egg-info
export PYBUILD_TEST_ARGS=http_proxy= https_proxy= python{version} -m pytest --ignore-glob=**/test_wsgi.py -n1
export LC_ALL=C.UTF-8
%:
dh $@ --with python3 --buildsystem=pybuild
|