1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
Author: Andreas Tille <tille@debian.org>
Last-Update: Thu, 29 Dec 2022 11:21:48 +0100
Bug-Debian: https://bugs.debian.org/1027252
Description: Fix AttributeError: module 'numpy' has no attribute 'float'
with numpy/1.24.1
@@ -68,13 +68,13 @@ _OPTIONAL_MODEL_ATTRIBUTES = {
def _fix_type(
- value: Union[str, np.float, np.bool, Set, Dict]
+ value: Union[str, float, bool, Set, Dict]
) -> Union[str, float, bool, List, OrderedDict]:
"""Convert possible types to correct Python types.
Parameters
----------
- value : str, np.float, np.bool, set, dict
+ value : str, float, bool, set, dict
The value to fix type for.
Returns
@@ -86,9 +86,9 @@ def _fix_type(
# Because numpy floats can not be pickled to json
if isinstance(value, str):
return str(value)
- if isinstance(value, np.float):
+ if isinstance(value, float):
return float(value)
- if isinstance(value, np.bool):
+ if isinstance(value, bool):
return bool(value)
if isinstance(value, set):
return list(value)
|