File: README.md

package info (click to toggle)
python-configshell-fb 1%3A1.1.28-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 236 kB
  • sloc: python: 3,277; makefile: 62
file content (40 lines) | stat: -rw-r--r-- 1,688 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
configshell-fb
==============

A Python library for building configuration shells
--------------------------------------------------
configshell-fb is a Python library that provides a framework
for building simple but nice CLI-based applications.

This runs with Python 2 and 2to3 is run by setup.py to run on Python 3.

configshell-fb development
--------------------------
configshell-fb is licensed under the Apache 2.0 license. Contributions are welcome.

Since configshell-fb is used most often with targetcli-fb, the
targetcli-fb mailing should be used for configshell-fb discussion.

 * Mailing list: [targetcli-fb-devel](https://lists.fedorahosted.org/mailman/listinfo/targetcli-fb-devel)
 * Source repo: [GitHub](https://github.com/open-iscsi/configshell-fb)
 * Bugs: [GitHub](https://github.com/open-iscsi/configshell-fb/issues) or [Trac](https://fedorahosted.org/targetcli-fb/)
 * Tarballs: [fedorahosted](https://fedorahosted.org/releases/t/a/targetcli-fb/)

Packages
--------
configshell-fb is packaged for a number of Linux distributions
including RHEL,
[Fedora](https://apps.fedoraproject.org/packages/python-configshell),
openSUSE, Arch Linux,
[Gentoo](https://packages.gentoo.org/packages/dev-python/configshell-fb), and
[Debian](https://tracker.debian.org/pkg/python-configshell-fb).

"fb" -- "free branch"
---------------------

configshell-fb is a fork of the "configshell" code written by
RisingTide Systems. The "-fb" differentiates between the original and
this version. Please ensure to use either all "fb" versions of the
targetcli components -- targetcli, rtslib, and configshell, or stick
with all non-fb versions, since they are no longer strictly
compatible.