1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
UPSTREAM_GIT := https://opendev.org/x/cursive.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=python_distutils --with python3,sphinxdoc
override_dh_auto_clean:
rm -rf build
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
pkgos-dh_auto_test --no-py2
endif
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html doc/source debian/python-cursive-doc/usr/share/doc/python-cursive-doc/html
dh_sphinxdoc
endif
|