1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78
|
Source: python-django-extra-views
Section: python
Priority: optional
Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders:
Michael Fladischer <fladi@debian.org>,
Build-Depends:
debhelper-compat (= 13),
dh-python,
python3-all,
python3-django,
python3-django-nose,
python3-pytest,
python3-pytest-django,
python3-setuptools,
python3-six,
python3-sphinx,
Standards-Version: 4.6.1.0
Homepage: https://github.com/AndrewIngram/django-extra-views/
Vcs-Browser: https://salsa.debian.org/python-team/packages/python-django-extra-views
Vcs-Git: https://salsa.debian.org/python-team/packages/python-django-extra-views.git
Rules-Requires-Root: no
Package: python-django-extra-views-doc
Section: doc
Architecture: all
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Multi-Arch: foreign
Description: Complementary class-based generic views for Django (Documentation)
Django Extra Views provides a number of additional class-based generic views to
complement those provide by Django itself.
.
Features:
* FormSet and ModelFormSet views - The formset equivalents of FormView and
ModelFormView.
* InlineFormSetView - Lets you edit formsets related to a model (uses
inlineformset_factory).
* CreateWithInlinesView and UpdateWithInlinesView - Lets you edit a model and
its relations.
* GenericInlineFormSetView, the equivalent of InlineFormSetView but for
GenericForeignKeys.
* Support for generic inlines in CreateWithInlinesView and
UpdateWithInlinesView.
* Support for naming each inline or formset with NamedFormsetsMixin.
* SortableListMixin - Generic mixin for sorting functionality in your views.
* SearchableListMixin - Generic mixin for search functionality in your views.
.
This package contains the documentation.
Package: python3-django-extra-views
Architecture: all
Depends:
${misc:Depends},
${python3:Depends},
Suggests:
python-django-extra-views-doc (= ${binary:Version}),
Description: Complementary class-based generic views for Django (Python3 version)
Django Extra Views provides a number of additional class-based generic views to
complement those provide by Django itself.
.
Features:
* FormSet and ModelFormSet views - The formset equivalents of FormView and
ModelFormView.
* InlineFormSetView - Lets you edit formsets related to a model (uses
inlineformset_factory).
* CreateWithInlinesView and UpdateWithInlinesView - Lets you edit a model and
its relations.
* GenericInlineFormSetView, the equivalent of InlineFormSetView but for
GenericForeignKeys.
* Support for generic inlines in CreateWithInlinesView and
UpdateWithInlinesView.
* Support for naming each inline or formset with NamedFormsetsMixin.
* SortableListMixin - Generic mixin for sorting functionality in your views.
* SearchableListMixin - Generic mixin for search functionality in your views.
.
This package contains the Python 3 version of the library.
|