File: control

package info (click to toggle)
python-expiringdict 1.1.4-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 112 kB
  • sloc: python: 132; makefile: 3
file content (28 lines) | stat: -rw-r--r-- 965 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Source: python-expiringdict
Section: python
Priority: optional
Maintainer: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
Build-Depends:
 debhelper-compat (= 12),
 dh-python,
 python3-all,
 python3-setuptools,
Homepage: https://github.com/mailgun/expiringdict
Standards-Version: 4.4.1
Vcs-Git: https://salsa.debian.org/python-team/modules/python-expiringdict.git -b debian/master
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-expiringdict
Rules-Requires-Root: no

Package: python3-expiringdict
Architecture: all
Depends:
 ${misc:Depends},
 ${python3:Depends},
Description: Python3 caching libarry
 expiringdict is a Python caching library, providing an ordered
 dictionary with auto-expiring values for caching purposes. Expiration
 happens on any access, object is locked during cleanup from expired
 values.  ExpiringDict stores at most a maximum number of elements -
 the oldest will be deleted.
 .
 This is the Python 3 version of this package.