1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
export PYBUILD_NAME=gsd
export PYBUILD_TEST_ARGS=$(CURDIR)/gsd/test
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_clean:
dh_clean
rm -f gsd/fl.c || /bin/true
rm -rf devdoc
rm -rf gsd/test/.pytest_cache
execute_after_dh_auto_build-indep: export http_proxy=127.0.0.1:9
execute_after_dh_auto_build-indep: export https_proxy=127.0.0.1:9
execute_after_dh_auto_build-indep:
doxygen
PYTHONPATH=$(shell pybuild --pyver `py3versions -dv` --print {build_dir}) READTHEDOCS=True sphinx-build -b html doc $(CURDIR)/.pybuild/html
execute_after_dh_python3:
dh_numpy3
|