File: changelog

package info (click to toggle)
python-markdown 3.1.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 2,824 kB
  • sloc: python: 6,798; makefile: 72; sh: 12
file content (467 lines) | stat: -rw-r--r-- 16,114 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
python-markdown (3.1.1-2) unstable; urgency=medium

  * Upload to unstable.
    - The 3.1 release is compatible with PyYaml 5.1 (closes: #933920).

  [ Ondřej Nový ]
  * Bump Standards-Version to 4.4.0.

 -- Dmitry Shachnev <mitya57@debian.org>  Mon, 05 Aug 2019 22:03:47 +0300

python-markdown (3.1.1-1) experimental; urgency=medium

  * New upstream release.
  * Build-depend and depend on python[3]-packaging.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 25 May 2019 13:42:45 +0300

python-markdown (3.1-1) experimental; urgency=medium

  * New upstream release.
  * Drop fix_double_escaping.diff, included in the new release.
  * Drop nose build-dependencies, no longer needed.
  * Update autopkgtests to use unittest instead of nose.
  * Add debian/gitlab-ci.yml using salsa-pipeline.
  * Update to debhelper compat level 12.
  * Update markdown_py(1) manpage, add a deprecation notice.

 -- Dmitry Shachnev <mitya57@debian.org>  Wed, 01 May 2019 12:55:38 +0300

python-markdown (3.0.1-3) unstable; urgency=medium

  * Drop ignore_yaml_deprecation_warnings.diff, bug #917603 is fixed now.
  * Backport upstream commit to fix double code escaping (closes: #919881).
  * Bump Standards-Version to 4.3.0, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 20 Jan 2019 19:00:05 +0300

python-markdown (3.0.1-2) unstable; urgency=medium

  * Make python3-markdown depend on python3-pkg-resources.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 23 Dec 2018 12:40:34 +0300

python-markdown (3.0.1-1) unstable; urgency=medium

  * New upstream release.
  * Drop add_mkdocs_config.diff, no longer needed.
  * Bump mkdocs build-dependency to 1.0.
  * Bump mkdocs-nature build-dependency to 0.3.1.
  * Use dh_mkdocs instead of dh_linktree.
  * Add Markdown.egg-info to pybuild.testfiles to make the tests pass.
  * Add a patch to ignore DeprecationWarnings from PyYAML module,
    to make the tests pass with Python 3.7.
  * Update to debhelper compatibility level 11.
  * Rewrite debian/copyright using copyright format 1.0.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 22 Dec 2018 22:40:39 +0300

python-markdown (2.6.11-3) unstable; urgency=medium

  * Make python3-markdown autopkgtest depend on python3-all, and
    use ‘py3versions -s’ instead of ‘py3versions -i’ (closes: #914994).

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 29 Nov 2018 14:43:51 +0300

python-markdown (2.6.11-2) unstable; urgency=medium

  * Make python-markdown depend on python-pkg-resources (closes: #913619).

 -- Dmitry Shachnev <mitya57@debian.org>  Tue, 13 Nov 2018 14:14:12 +0300

python-markdown (2.6.11-1) unstable; urgency=medium

  [ Dmitry Shachnev ]
  * New upstream release.
  * Remove Fredrik Steen from Uploaders list (closes: #877098).
  * Add build-dependencies on setuptools.
  * Add mkdocs.yml from upstream repository (add_mkdocs_config.diff).
  * Build the documentation using mkdocs.
  * Skip building python-markdown-doc with nodoc build profile.
  * Add a patch to disable use_directory_urls mkdocs option,
    to make it easier to browse the documentation locally.
  * Symlink static files in python-markdown-doc.
  * Update links in debian/README.Debian.
  * Drop dh_auto_test override, rely on pybuild magic to run the tests.
  * Bump Standards-Version to 4.2.1, no changes needed.

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/changelog: Remove trailing whitespaces
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field

 -- Dmitry Shachnev <mitya57@debian.org>  Wed, 07 Nov 2018 09:44:55 +0300

python-markdown (2.6.9-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Update Homepage URL.
  * Bump Standards-Version to 4.0.1, no changes needed.
  * Update debian/copyright.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 18 Aug 2017 11:12:44 +0300

python-markdown (2.6.8-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Bump Standards-Version to 3.9.8, no changes needed.
  * Add a debian/copyright entry for markdown/extensions/smartypants.py.

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 26 Jan 2017 09:59:09 +0300

python-markdown (2.6.7-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Use https in debian/watch.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 25 Sep 2016 14:09:10 +0300

python-markdown (2.6.6-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Bump Standards-Version to 3.9.7, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Mon, 21 Mar 2016 07:47:01 +0100

python-markdown (2.6.5-2) unstable; urgency=medium

  * Add python3-tidylib to build-dependencies and test dependencies, now
    that it's available.
  * Cherry-pick upstream commit to make code highlighting tests work with
    Pygments 2.1 (closes: #813028).
  * Update Vcs-Git field to use HTTPS, which is now the recommended protocol
    (refs #810378).

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 29 Jan 2016 08:32:30 +0300

python-markdown (2.6.5-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Drop XS-Testsuite header, not needed with recent dpkg versions.

 -- Dmitry Shachnev <mitya57@debian.org>  Thu, 26 Nov 2015 18:59:49 +0300

python-markdown (2.6.4-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Cherry-pick upstream patch to fix a regression in tables processing.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 13 Nov 2015 17:51:57 +0300

python-markdown (2.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Update Vcs fields for git migration.

 -- Dmitry Shachnev <mitya57@debian.org>  Tue, 27 Oct 2015 15:14:04 +0300

python-markdown (2.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Bring debian/markdown_py.1 in sync with upstream help output.
  * Add some missing information to debian/copyright.
  * Bump python-all build-dependency to a version that introduced
    Python 2.7.
  * Upload to unstable.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 24 Apr 2015 12:50:39 +0300

python-markdown (2.6.1-1) experimental; urgency=medium

  * New upstream bugfix release.
  * Update package descriptions.

 -- Dmitry Shachnev <mitya57@debian.org>  Mon, 09 Mar 2015 18:44:45 +0300

python-markdown (2.6-1) experimental; urgency=medium

  * New upstream release.
    - No longer calls logging.captureWarnings on input (closes: #776591).
  * Update debian/watch to point to pypi.debian.net.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 20 Feb 2015 11:00:34 +0300

python-markdown (2.5.2-1) experimental; urgency=medium

  * New upstream bugfix release.
  * Drop disable_wrong_tests.patch, no longer needed.
  * Bump Standards-Version to 3.9.6, no changes needed.

 -- Dmitry Shachnev <mitya57@debian.org>  Fri, 21 Nov 2014 09:17:16 +0300

python-markdown (2.5.1-2) unstable; urgency=medium

  * Disable two tests that were relying on wrong assumption about Pygments
    lexer guessing algorithm (closes: #767579).

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 01 Nov 2014 12:34:55 +0300

python-markdown (2.5.1-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Dmitry Shachnev <mitya57@debian.org>  Sat, 04 Oct 2014 10:57:08 +0400

python-markdown (2.5-2) unstable; urgency=medium

  * Bump X-Python-Version to 2.7 and X-Python3-Version to 3.2,
    following upstream changes.
  * Add python(3)-yaml and python(3)-pygments to autopkgtest
    dependencies as well.

 -- Dmitry Shachnev <mitya57@debian.org>  Mon, 15 Sep 2014 14:00:09 +0400

python-markdown (2.5-1) unstable; urgency=medium

  [ Andrey Rahmatullin ]
  * Convert to pybuild.

  [ Dmitry Shachnev ]
  * New upstream release.
  * Simplify debian/rules.
  * Drop upstream smarty_fixes.patch.
  * Build-depend on and recommend python(3)-yaml.
  * Also build-depend on python(3)-pygments.
  * Run wrap-and-sort.
  * Update my e-mail address.

 -- Dmitry Shachnev <mitya57@debian.org>  Sun, 14 Sep 2014 11:40:01 +0400

python-markdown (2.4.1-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Backport upstream commits to make smarty extension work together
    with attr_list.

 -- Dmitry Shachnev <mitya57@gmail.com>  Tue, 27 May 2014 12:51:34 +0400

python-markdown (2.4-1) unstable; urgency=low

  [ Dmitry Shachnev ]
  * New upstream release.
  * Bump Standards-Version to 3.9.5, no changes needed.
  * Add explicit build-dependency on dh-python.

  [ Bernd Zeimetz ]
  * Removing myself from Uploaders.

 -- Dmitry Shachnev <mitya57@gmail.com>  Mon, 17 Feb 2014 15:19:36 +0400

python-markdown (2.3.1-2) unstable; urgency=low

  * Update man page:
    - Correctly escape hyphens.
    - Make DESCRIPTION section come after SYNOPSIS and remove
      AUTHOR section.
  * Really remove suggestion of python-utidylib, HTML Tidy extension
    has been removed in 2.3.
  * debian/watch: use HTTPS, and correctly escape dots.
  * Update debian/copyright (closes: #728134, thanks Luke Faraone).

 -- Dmitry Shachnev <mitya57@gmail.com>  Tue, 29 Oct 2013 20:14:29 +0400

python-markdown (2.3.1-1) unstable; urgency=low

  * New upstream release, with native Python 3 support.
  * Build-depend on python-tidylib instead of python-utidylib,
    and drop python-markdown dependency on python-utidylib.
  * debian/rules, debian/tests: use /usr/bin/nosetests for all Python
    versions, and make the tests output more verbose.
  * Force buildsystem to be python_distutils.
  * Update debian/README.Debian.
  * Drop obsolete DM-Upload-Allowed flag.
  * Bump Standards-Version to 3.9.4, no changes needed.
  * Bump debhelper compat level to 9.
  * Use canonical Vcs-Svn field.

 -- Dmitry Shachnev <mitya57@gmail.com>  Sat, 23 Mar 2013 14:51:20 +0400

python-markdown (2.2.1-3) unstable; urgency=low

  * Redirect tests stderr to stdout and don't set -x, thanks to Martin Pitt
    (closes: #692813)
  * Update to 2012-11-09 from upstream git

 -- Dmitry Shachnev <mitya57@gmail.com>  Wed, 14 Nov 2012 09:03:07 +0400

python-markdown (2.2.1-2) unstable; urgency=low

  * debian/tests/control: fix wrong dependency for python3-markdown test

 -- Dmitry Shachnev <mitya57@gmail.com>  Tue, 06 Nov 2012 10:48:11 +0400

python-markdown (2.2.1-1) unstable; urgency=low

  * New upstream release
  * Simplify .install files
  * Add python-utidylib to python-markdown Suggests (for html_tidy extension)
    and to Build-Depends (for testsuite)
  * git_fix_tests.patch: dropped, no longer needed
  * Add DEP-8 tests
  * debian/rules: skip tests for Python versions unsupported by nose

 -- Dmitry Shachnev <mitya57@gmail.com>  Mon, 05 Nov 2012 13:28:13 +0400

python-markdown (2.2.0-1) unstable; urgency=low

  * New upstream release
  * Recommend python[3]-pygments packages (needed for codehilite extension)
  * Adjust to upstream documentation changes
  * Don't compress text files that go with the documentation
  * git_fix_inline_html.patch: dropped, applied in the new release
  * git_fix_tests.patch: patch from upstream git to fix test suite failures

 -- Dmitry Shachnev <mitya57@gmail.com>  Sun, 29 Jul 2012 14:20:06 +0400

python-markdown (2.1.1-3) unstable; urgency=low

  [ Dmitry Shachnev ]
  * Bump Standards-Version to 3.9.3
  * Make module packages suggest the doc package
  * Add doc-base file
  * Run tests during build
  * Add debian/patches/git_fix_inline_html.patch to fix issues with
    inline html handling (closes: #646552)

  [ Bernd Zeimetz ]
  * Setting DM-Upload-Allowed: yes

 -- Bernd Zeimetz <bzed@debian.org>  Sat, 05 May 2012 22:31:31 +0200

python-markdown (2.1.1-2) unstable; urgency=low

  * Switch to debhelper 8
  * Add python-markdown-doc package

 -- Dmitry Shachnev <mitya57@gmail.com>  Thu, 16 Feb 2012 19:06:04 +0400

python-markdown (2.1.1-1) unstable; urgency=low

  * Add myself to Uploaders
  * New upstream release
  * Add debian/markdown_py.1 manpage
  * Drop 01-fix-unusual-interpreter.patch, fixed upstream

 -- Dmitry Shachnev <mitya57@gmail.com>  Wed, 25 Jan 2012 13:26:18 +0400

python-markdown (2.1.0-1) unstable; urgency=low

  [ Dmitry Shachnev ]
  * New upstream release
  * Use 3.0 (quilt) source format
  * Port to dh_python*
  * Build Python3 package (closes: #647094)
  * debian/patches/01-fix-unusual-interpreter.patch:
    - fix interpreter in def_list and tables extensions
  * Bump Standards-Version to 3.9.2, no changes required

 -- Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>  Sun, 22 Jan 2012 15:24:30 +0400

python-markdown (2.0.3-2) unstable; urgency=low

  * Rename /usr/bin/markdown to /usr/bin/markdown_py for now. The Python
    implementation is not compatible enough to be an alternative for the Perl
    version yet. (Closes: #567378)
  * Get rid of the new source format mess, we use the default.
  * Add .PHONY to debian/rules.
  * Bump Standards-Version to 3.8.4 - no changes needed.
  * Drop XB-Python-Version, not needed.

 -- Bernd Zeimetz <bzed@debian.org>  Wed, 24 Feb 2010 23:24:10 +0100

python-markdown (2.0.3-1) unstable; urgency=low

  [ Raphaël Hertzog ]
  * New upstream release. Closes: #525563
  * Remove myself from Uploaders.
  * Update watch file to point to pypi.
  * Switch to source format "3.0 (quilt)".
  * Fix URL in README.Debian. Closes: #532416
  * Switch to debhelper 7 tiny rules files and compat mode 7.
  * Build-depends on python instead of python-dev.
  * Update Standards-Version to 3.8.3.

 -- Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>  Wed, 27 Jan 2010 17:48:00 +0100

python-markdown (1.7-2) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

  [ Emilio Pozuelo Monfort ]
  * debian/rules: Don't rely on python-support directory
    structure. Thanks Josselin Mouette. Closes: #517061.
  * Standards-Version is 3.8.0. No changes needed.

 -- Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>  Wed, 25 Feb 2009 23:35:20 +0100

python-markdown (1.7-1) unstable; urgency=low

  [ Bernd Zeimetz ]
  * New upstream version.
  * debian/control:
    - Adding Homepage field, removing pseudo-field from description
    - Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)
    - Updating my email address
    - Bumping Standards-Version to 3.7.3 - no changes needed.

  [ Sandro Tosi ]
  * debian/control
    - uniforming Vcs-Browser field

 -- Bernd Zeimetz <bzed@debian.org>  Sun, 02 Mar 2008 23:43:50 +0100

python-markdown (1.6b-1) unstable; urgency=low

  * New upstream version

 -- Bernd Zeimetz <bernd@bzed.de>  Sun, 19 Aug 2007 01:41:04 +0200

python-markdown (1.6a-1) unstable; urgency=low

  * New upstream version (Closes: #398856)
  * debian/control:
    - Added XS-Vcs-Browser, XS-Vcs-Svn field
    - Moved python-support to Build-Depends, fixing lintian
      error clean-should-be-satisfied-by-build-depends
  * debian/watch:
    - Updating watch file - upstream ships a .zip file now
  * debian/changelog.pointer:
    - Removing file, upstream ships a changelog now
  * debian/README.Debian:
    - Updated, upstream ships a changelog now
  * debian/copyright:
    - Reflecting upstreams change in licensing, markdown is dual-licensed
      under GPL-2 and BSD now
  * debian/dirs:
    - Removing file, not needed anymore
  * debian/compat:
    - Bumping to level 5

 -- Bernd Zeimetz <bernd@bzed.de>  Sat, 18 Aug 2007 14:36:15 +0200

python-markdown (1.4-2) unstable; urgency=low

  * Acknowledge previous NMU. Closes: #374865
  * Update to new python policy. Closes: #373326
  * Updated Standards-Version.
  * Added myself to uploaders.

 -- Raphael Hertzog <hertzog@debian.org>  Fri, 23 Jun 2006 10:48:53 +0200

python-markdown (1.4-1.1) unstable; urgency=high

  * Non-maintainer upload.
  * Build-depend on python-dev instead of python; fixes FTBFS, patch from
    Andreas Jochens. (Closes: #373201)

 -- Steinar H. Gunderson <sesse@debian.org>  Tue, 20 Jun 2006 23:53:45 +0200

python-markdown (1.4-1) unstable; urgency=low

  * Initial release Closes: #364082

 -- Fredrik Steen <stone@debian.org>  Fri, 21 Apr 2006 13:18:31 +0200