1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
TESTRUNNER=py.test
export PYBUILD_NAME = mne
export ETS_TOOLKIT=qt4
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
%:
dh $@ --with python2 --buildsystem pybuild
override_dh_clean:
rm -rf *.egg-info
dh_clean
override_dh_auto_build:
dh_auto_build
yui-compressor debian/JS/bootstrap/bootstrap.js > $(CURDIR)/mne/html/bootstrap.min.js
printf "\n\n" >> $(CURDIR)/mne/html/bootstrap.min.js
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
mkdir -p build
HOME=$(CURDIR)/build \
MNE_DONTWRITE_HOME=true MNE_SKIP_SAMPLE_DATASET_TESTS=true MNE_FORCE_SERIAL=true MNE_SKIP_NETWORK_TESTS=1 \
xvfb-run --auto-servernum --server-num=20 -s "-screen 0 1024x768x24 -ac +extension GLX +render -noreset" \
$(TESTRUNNER) -s -v mne || true
endif
override_dh_fixperms:
dh_fixperms
find `find debian -name data -type d` -type f -exec chmod -x \{\} \;
|