1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
include /usr/share/dpkg/pkg-info.mk
export DH_ALWAYS_EXCLUDE=__pycache__
export DH_VERBOSE = 1
export PYBUILD_VERBOSE=1
export PYBUILD_NAME=nudatus
%:
dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_clean:
dh_auto_clean
rm -rf __pycache__
override_dh_auto_build:
dh_auto_build
@echo DEB_VERSION_UPSTREAM $(DEB_VERSION_UPSTREAM)
sed -e "s/__VERSION__/$(DEB_VERSION_UPSTREAM)/g" \
< debian/nudatus.1.md.in > debian/nudatus.1.md
pandoc debian/nudatus.1.md -s -f markdown -t man -o debian/nudatus.1
|