File: changelog

package info (click to toggle)
python-openid 2.2.5-7
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 1,724 kB
  • sloc: python: 16,741; xml: 234; sh: 31; makefile: 8
file content (222 lines) | stat: -rw-r--r-- 7,430 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
python-openid (2.2.5-7) unstable; urgency=medium

  [ Chris Lamb ]
  * Team upload
  * debian/watch: Move away from deprecated githubredir redirector.
  * Bump Standards-Version to 4.2.1.
  * Move to debhelper compat level 11.

  [ Ondřej Nový ]
  * Fixed homepage (https)
  * Fixed VCS URL (https)
  * d/control: Set Vcs-* to salsa.debian.org
  * d/changelog: Remove trailing whitespaces
  * Convert git repository from git-dpm to gbp layout

 -- Chris Lamb <lamby@debian.org>  Tue, 18 Sep 2018 18:24:59 +0100

python-openid (2.2.5-6) unstable; urgency=low

  * Fixing changelog of previous botched release
    (wrong .changes file got uploaded).

 -- Mikhail Gusarov <dottedmag@debian.org>  Tue, 02 Sep 2014 01:34:52 +0200

python-openid (2.2.5-5) unstable; urgency=medium

  * Errorneous release.

 -- Mikhail Gusarov <dottedmag@debian.org>  Sun, 31 Aug 2014 18:38:04 +0200

python-openid (2.2.5-4) unstable; urgency=low

  [ Mikhail Gusarov ]
  * Fix version reported in openid.__version__ (Closes: #754774).
  * Fix openid.sqlstore crash with long nonce (Closes: #704698).
  * Switch to dh_python2 from python-support (suggested by Lintian).
  * Bump Standards-Version, no changes required.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

 -- Mikhail Gusarov <dottedmag@debian.org>  Sun, 31 Aug 2014 18:12:46 +0200

python-openid (2.2.5-3) unstable; urgency=low

  * Add missing build-dependency to python-epydoc (Closes: #622228).

 -- Mikhail Gusarov <dottedmag@debian.org>  Mon, 11 Apr 2011 10:22:43 +0200

python-openid (2.2.5-2) unstable; urgency=low

  * Split out -doc package (Closes: #620977):
    - debian/control: New package entry.
    - debian/examples, debian/python-openid.doc-base,
      debian/python-openid.docs: Renamed.
    - debian/rules: Adjust installation directories.
  * debian/python-openid.preinst: Remove workaround for upgrading from
    Lenny, as Squeeze is released.
  * debian/source/format: Upgrade to 3.0 (quilt).

 -- Mikhail Gusarov <dottedmag@debian.org>  Fri, 08 Apr 2011 19:31:19 +0200

python-openid (2.2.5-1) unstable; urgency=low

  * New upstream release.
  * debian/control:
    - Update my e-mail address.
    - Update homepage as upstream moved to GitHub.
    - Bump Standards-Version to 3.9.1, no changes required.
    - Add python-epydoc to Build-Depends to generate documentation during
      build.
  * debian/watch:
    - Update download URL as upstream moved to GitHub.
  * debian/rules:
    - Generate epydoc documentation during build.

 -- Mikhail Gusarov <dottedmag@debian.org>  Fri, 25 Mar 2011 10:30:17 +0100

python-openid (2.2.4-2) unstable; urgency=low

  * debian/pycompat: remove useless file.
  * debian/control:
    - remove X[BS]-Python-Versions,
    - bump Standards-Version to 3.8.3, no changes required.
  * Rename debian/docs to debian/python-openid.docs.
  * debian/rules:
    - rewrite to use dh 7.
  * debian/python-openid.doc-base: added.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Thu, 10 Sep 2009 22:52:45 +0700

python-openid (2.2.4-1) unstable; urgency=low

  * New upstream release:
    - removed build-extensions.patch, applied upstream,
    - removed quilt dependency, unused.
    - removed README.source, no more quilt.
  * Switched to debian-support:
    - added preinst script to de-register from pycentral.
  * Standards-Version bumped to 3.8.1, no changes needed.
  * python-all-dev build-dependency relaxed to python, as no binary
    modules are built.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Fri, 01 May 2009 00:04:57 +0700

python-openid (2.2.1-3) unstable; urgency=low

  * debian/copyright:
    - replaced (C) with ©, as suggested by Lintian,
    - debian packaging is under Apache-2.0 as well.
  * debian/rules:
    - replaced deprecated dh_clean -k with dh_prep,
    - clean target now unpatches the source code.
  * debian/control:
    - expanded package description, as suggested by Lintian.
  * debian/patches/build-extensions.patch:
    - added description, as suggested by Lintian.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Tue, 17 Feb 2009 00:56:25 +0600

python-openid (2.2.1-2) unstable; urgency=medium

  [ Mikhail Gusarov ]
  * Fixed debian/copyright: library changed license to Apache-2.0
    (Closes: #514064)
  * debian/README.source added.

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Wed, 04 Feb 2009 03:48:30 +0700

python-openid (2.2.1-1) unstable; urgency=low

  * New upstream release:
    - fix-openid1.0-compatibility.patch removed, included upstream.
  * Debhelper compatibility level bumped to 7:
    - manual stamp-file deletion removed from debian/rules (it was
    incorrect btw);
    - debhelper debpendency bumped.
  * Standards-Version bumped to 3.8.0:
    - Homepage added to debian/control.
  * python-central dependency moved to Build-Depends-Indep as suggested by
    lintian.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Mon, 30 Jun 2008 01:24:49 +0700

python-openid (2.1.1-1) unstable; urgency=low

  [ Mikhail Gusarov ]
  * New upstream release (Closes: #465699, #457081).

  * Get rid of CDBS and use debhelper directly.
    - cdbs dependency removed.
  * Depend on pycentral >= 0.6 to avoid bug #452227.

  * Added patch fix-openid1.0-compatibility.patch, cherry-picked from
    upstream (Closes: #471798).
  * build-extensions.patch refreshed.

  * Standards-Version bumped to 3.7.3, no changes required.

  [ Sandro Tosi ]
  * debian/watch
    - fixed version regexp to consider only numerical versions.
  * debian/control
    - added Vcs-Svn and Vcs-Browser.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Fri, 21 Mar 2008 12:50:26 +0600

python-openid (2.0.2-1) unstable; urgency=low

  * New upstream release.
  * urljr and yadis libraries are now in openid - dropping dependencies
    (Closes: #441926).
  * Package can now be built twice in a row. Thanks for clean solution
    goes to Kumar Appaiah (Closes: #442713).
  * quilt added to manage patches.
  * Added patch build-extensions.patch, enabling openid.extensions to be
    packaged.
  * Watch file updated.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Sat, 15 Sep 2007 14:09:38 +0700

python-openid (2.0.1-1) unstable; urgency=low

  * New upstream release (Closes: #430620)
    - Example Django server fixed(Closes: #429355, #429628).
  * Rebuilding package to get .egg information (Closes: #434536).
  * Do not compress examples, they are executable python code
    (Closes: #429630).
  * epydoc documentation moved to html/ subdir to avoid polluting
    top-level directory.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Wed, 04 Jul 2007 14:06:56 +0700

python-openid (2.0.0-1) unstable; urgency=low

  * New upstream release.
  * Install more upstream documentation.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Sat, 12 May 2007 14:20:25 +0700

python-openid (1.2.0-1) unstable; urgency=low

  * New upstream release.
  * Install upstream changelog as well.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Sat, 16 Dec 2006 02:06:59 +0600

python-openid (1.1.0-2) unstable; urgency=low

  * Copyright file updated to satisfy Debian requirements.

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Sat, 18 Nov 2006 21:21:28 +0600

python-openid (1.1.0-1) unstable; urgency=low

  * Initial revision. (Closes: #394467)

 -- Mikhail Gusarov <dottedmag@dottedmag.net>  Sat, 21 Oct 2006 19:36:04 +0700