1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
|
UPSTREAM_GIT = git://github.com/openstack/os-refresh-config.git
include /usr/share/openstack-pkg-tools/pkgos.make
export OSLO_PACKAGE_VERSION=$(VERSION)
%:
dh $@ --buildsystem=python_distutils --with python2
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
set -e && \
TEMP_REZ=`mktemp -t` && \
python setup.py testr --slowest --testr-args='--subunit ' \
| tee $$TEMP_REZ | subunit2pyunit && \
cat $$TEMP_REZ | subunit-filter -s --no-passthrough | subunit-stats && \
rm -f $$TEMP_REZ
endif
|