1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
UPSTREAM_GIT := https://github.com/openstack/os-win.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3,sphinxdoc
override_dh_auto_clean:
python3 setup.py clean
rm -rf build .stestr doc/source/_static *.egg-info
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
pkgos-dh_auto_test --no-py2 'os_win\.tests\.unit\.(?!(.*utils\.compute\.test_clusapi_utils\.ClusApiUtilsTestCase\.test_get_cluster_group_type.*))'
endif
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html doc/source debian/python-os-win-doc/usr/share/doc/python-os-win-doc/html
dh_sphinxdoc
endif
|