1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
UPSTREAM_GIT := https://github.com/openstack/oslo.privsep.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3,sphinxdoc
override_dh_auto_clean:
for i in $$(find $(CURDIR) -type d -name __pycache__) ; do \
rm -rf $$i ; \
done
rm -rf build .stestr AUTHORS ChangeLog *.egg-info
rm -rf doc/source/reference/api
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
for i in $(PYTHON3S) ; do \
python3 setup.py install -f --install-layout=deb --root=$(CURDIR)/debian/tmp ; \
done
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages pkgos-dh_auto_test --no-py2
endif
override_dh_auto_test:
echo "Do nothing..."
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHON=python3 python3 -m sphinx -b html doc/source debian/python-oslo.privsep-doc/usr/share/doc/python-oslo.privsep-doc/html
dh_sphinxdoc
endif
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
|