File: changelog

package info (click to toggle)
python-pam 0.4.2-13.2
  • links: PTS
  • area: main
  • in suites: buster, sid, stretch
  • size: 108 kB
  • ctags: 51
  • sloc: ansic: 518; python: 50; makefile: 44
file content (168 lines) | stat: -rw-r--r-- 5,200 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
python-pam (0.4.2-13.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Build using dh-python. Closes: #786291.

 -- Matthias Klose <doko@debian.org>  Tue, 18 Aug 2015 19:00:37 +0200

python-pam (0.4.2-13.1) unstable; urgency=low

  * Non-maintainer upload.
  * debian/control: Change X-Python-Version to >= 2.6 to not explicitly
    request Python 2.6. (Closes: #707531)

 -- Sebastian Ramacher <sramacher@debian.org>  Fri, 05 Jul 2013 02:38:29 +0200

python-pam (0.4.2-13) unstable; urgency=high

  * Acknowledged NMUs
  * Fixed a security vulnerability in PyPAM_conv
    (thanks Markus Vervier <markus.vervier@lsexperts.de> 
    for the report and the patch)

 -- Dima Barsky <dima@debian.org>  Tue, 06 Mar 2012 21:48:38 +0000

python-pam (0.4.2-12.3) unstable; urgency=low

  * Non-maintainer upload.
  * Use python-support (closes: #620283).
    + Add build-dependency on python-support.
    + In debian/rules, replace call to dh_python with dh_pysupport.

 -- Jakub Wilk <jwilk@debian.org>  Fri, 08 Apr 2011 21:08:10 +0200

python-pam (0.4.2-12.2) unstable; urgency=low

  * Non-maintainer upload.
  * Remove build-dependency on python2.5-dev. Closes: #596314.

 -- Matthias Klose <doko@debian.org>  Sun, 12 Sep 2010 15:37:47 +0200

python-pam (0.4.2-12.1) unstable; urgency=low

  * Non-maintainer upload.
  * Prepare for the upcoming Python 2.6 transition; thanks to Piotr O┼╝arowski
    for the bug report and to Kumar Appaiah for the patch; Closes: #556162
    - debian/rules
      + optionally include python.mk, add $(py_setup_install_args) and
        --prefix=/usr when installing

 -- Sandro Tosi <morph@debian.org>  Sun, 15 Nov 2009 21:36:54 +0100

python-pam (0.4.2-12) unstable; urgency=low

  * Added Build-Depends: python2.5-dev (Closes: #415377)

 -- Dima Barsky <dima@debian.org>  Mon, 19 Mar 2007 15:51:05 +0000

python-pam (0.4.2-11) unstable; urgency=low

  * Acknowledged NMUs
  * Added 2.5 support (thanks to Harro Verkouter <verkouter@jive.nl>)

 -- Dima Barsky <dima@debian.org>  Sat, 17 Mar 2007 17:46:16 +0000

python-pam (0.4.2-10.4) unstable; urgency=low

  * Non-maintainer upload.
  * Add the missing Conflicts/Replaces on python2.X-pam.

 -- Raphael Hertzog <hertzog@debian.org>  Thu, 29 Jun 2006 08:46:49 +0200

python-pam (0.4.2-10.3) unstable; urgency=low

  * Non-maintainer upload.
  * Switch to the new Python policy. Closes: #373335

 -- Raphael Hertzog <hertzog@debian.org>  Sun, 25 Jun 2006 17:34:49 +0200

python-pam (0.4.2-10.2) unstable; urgency=low

  * Non-maintainer upload.
  * Stop building module for python2.1 and python2.2. (Closes: #351148)
  * Also support python2.4.

 -- Pierre Habouzit <madcoder@debian.org>  Sun,  9 Apr 2006 19:38:00 +0200

python-pam (0.4.2-10.1) unstable; urgency=low

  * NMU.
  * Change package section to python.
  * Make python dependency more robust.
  * Make python-pam package architecture all.

 -- Matthias Klose <doko@debian.org>  Sun, 28 Sep 2003 17:27:51 +0200

python-pam (0.4.2-10) unstable; urgency=low

  * Python2.3 is the default version now

 -- Dima Barsky <dima@debian.org>  Sat,  9 Aug 2003 19:44:56 +0100

python-pam (0.4.2-9) unstable; urgency=low

  * Removed all calls to dlopen and dlclose. Not sure why they were
    required before, but they only cause problems now. (Closes: #192005)

 -- Dima Barsky <dima@debian.org>  Sat, 10 May 2003 19:37:43 +0100

python-pam (0.4.2-8) unstable; urgency=low

  * python2.2-pam: now conflicts with python-pam (<=0.4.2-6)
    (Closes: #182949)
  * Added userData parameter to pam_conv function in pamtest.py,
    this test was broken in 0.4.2-7

 -- Dima Barsky <dima@debian.org>  Mon, 10 Mar 2003 21:51:02 +0000

python-pam (0.4.2-7) unstable; urgency=low

  * Build three versions of python-pam for all Python
    versions (Closes: #181325)
  * Added user argument to the conversation method, thanks to Benjamin
    Poussin <poussin@codelutin.com> for the patch. (Closes: #170972)

 -- Dima Barsky <dima@debian.org>  Sun, 23 Feb 2003 10:55:15 +0000

python-pam (0.4.2-6) unstable; urgency=low

  * Removed compiled binary examples/pamexample from the package

 -- Dima Barsky <dima@debian.org>  Sat, 26 Oct 2002 02:49:54 +0100

python-pam (0.4.2-5) unstable; urgency=low

  * Added build dependency on libpam0g-dev (Closes: #166365)

 -- Dima Barsky <dima@debian.org>  Fri, 25 Oct 2002 20:38:46 +0100

python-pam (0.4.2-4) unstable; urgency=low

  * Taken over from Gregor Hoffleit
  * Compiled against python 2.2
  * Replaced autoconf/automake by setup.py script
  * Bumped up Standards-Sersion to 3.5.7

 -- Dima Barsky <dima@debian.org>  Wed, 16 Oct 2002 14:45:50 +0100
  
python-pam (0.4.2-3) unstable; urgency=low

  * Recompiled for unstable (closes: #66359).
  * Fixed buglet in examples/pamtest.py.

 -- Gregor Hoffleit <flight@debian.org>  Sun, 28 Jan 2001 20:35:44 +0100

python-pam (0.4.2-2) unstable; urgency=low

  * FHS transition: move documentation to /usr/share/doc.
  * Bumped up standards-version to 3.1.0.

 -- Gregor Hoffleit <flight@debian.org>  Thu, 13 Jan 2000 00:06:45 +0100

python-pam (0.4.2-1) unstable; urgency=low

  * Initial Release.

 -- Gregor Hoffleit <flight@debian.org>  Sat, 28 Aug 1999 19:20:23 +0200