1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397
|
python-psutil (5.5.1-1) unstable; urgency=medium
* New upstream release
-- Sandro Tosi <morph@debian.org> Sat, 16 Feb 2019 19:44:57 -0500
python-psutil (5.5.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/changelog: Remove trailing whitespaces.
[ Sandro Tosi ]
* New upstream release
* debian/copyright
- extend packaging copyright years
* debian/control
- bump Standards-Version to 4.3.0 (no changes needed)
-- Sandro Tosi <morph@debian.org> Mon, 28 Jan 2019 23:20:40 -0500
python-psutil (5.4.8-1) unstable; urgency=medium
[ Ondřej Nový ]
* Convert git repository from git-dpm to gbp layout
[ Sandro Tosi ]
* New upstream release
* debian/control
- bump Standards-Version to 4.2.1 (no changes needed)
-- Sandro Tosi <morph@debian.org> Fri, 23 Nov 2018 14:36:51 -0500
python-psutil (5.4.6-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
* d/control: Remove ancient X-Python3-Version field
[ Sandro Tosi ]
* New upstream release
* debian/copyright
- extend packaging copyright years
* debian/control
- bump Standards-Version to 4.1.4 (no changes needed)
* debian/patches/*.patch
- rebase for new upstream code
-- Sandro Tosi <morph@debian.org> Thu, 07 Jun 2018 20:46:43 -0400
python-psutil (5.4.2-1) unstable; urgency=medium
* New upstream release
* debian/control
- bump Standards-Version to 4.1.2 (no changes needed)
-- Sandro Tosi <morph@debian.org> Sun, 10 Dec 2017 21:10:10 -0500
python-psutil (5.4.1-1) unstable; urgency=medium
* New upstream release; Closes: #881602
* debian/control
- bump Standards-Version to 4.1.1 (no changes needed)
- remove all Priority: extra
- move to python3-sphinx
- add python3-sphinx-rtd-theme to b-d, needed for doc
* debian/rules
- use upstream Makefile to run tests
- build doc with python3
-- Sandro Tosi <morph@debian.org> Sat, 25 Nov 2017 20:51:53 -0500
python-psutil (5.0.1-1) unstable; urgency=medium
* New upstream release
* debian/copyright
- extend packaging copyright years
-- Sandro Tosi <morph@debian.org> Thu, 05 Jan 2017 14:23:41 -0500
python-psutil (5.0.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* New upstream release
* d/copyright: Changed licence shortname from BSD to BSD-3-clause
* Bumped debhelper compat version to 10
* d/watch: Use https
* Enabled autopkgtest-pkg-python testsuite
-- Sandro Tosi <morph@debian.org> Sun, 11 Dec 2016 17:46:55 -0500
python-psutil (4.3.1-1) unstable; urgency=medium
* New upstream release
-- Sandro Tosi <morph@debian.org> Sun, 02 Oct 2016 15:56:41 -0400
python-psutil (4.2.0-1) unstable; urgency=medium
* New upstream release
* debian/control
- bump Standards-Version t0 3.9.8 (no changes needed)
-- Sandro Tosi <morph@debian.org> Sat, 11 Jun 2016 21:14:47 +0100
python-psutil (4.1.0-1) unstable; urgency=medium
[ Sandro Tosi ]
* New upstream release
* debian/python-psutil-doc.examples
- install examples from 'scripts' directory
* debian/rules
- run build also for the debug flavor
- run unittests via runner.py
* debian/control
- bump Standards-Version t0 3.9.7 (no changes needed)
[ Ondřej Nový ]
* Fixed VCS URL
-- Sandro Tosi <morph@debian.org> Sun, 10 Apr 2016 20:41:01 +0100
python-psutil (3.4.2-1) unstable; urgency=medium
* New upstream release
* debian/control
- redirect Vcs-Git to https
-- Sandro Tosi <morph@debian.org> Mon, 08 Feb 2016 22:23:04 +0000
python-psutil (3.4.1-1) unstable; urgency=medium
* New upstream release
* debian/copyright
- extend packaging copyright years
* debian/control
- add ipaddress and mock to b-d (needed by tests)
* bump dh compat to 9
-- Sandro Tosi <morph@debian.org> Sun, 17 Jan 2016 21:03:15 +0000
python-psutil (2.2.1-3) unstable; urgency=medium
* upload to unstable; Closes: #794679
-- Sandro Tosi <morph@debian.org> Fri, 14 Aug 2015 21:41:57 +0100
python-psutil (2.2.1-2) experimental; urgency=medium
* debian/{control, rules}
- provide -dbg packages
* provide -doc package
-- Sandro Tosi <morph@debian.org> Sun, 15 Feb 2015 16:38:21 +0000
python-psutil (2.2.1-1) experimental; urgency=medium
* New upstream release
* debian/watch
- use PyPI redirector
* debian/copyright
- extend packaging copyright years
-- Sandro Tosi <morph@debian.org> Fri, 06 Feb 2015 20:27:15 +0000
python-psutil (2.2.0-1) experimental; urgency=medium
* New upstream release
- fix file descriptors leakage; thanks to Marc Leeman; Closes: #772543
* debian/control
- update Homepage to github
- bump Standards-Version to 3.9.6 (no changes needed)
* debian/rules
- update upstream changelog
- install README.rst file in doc too
-- Sandro Tosi <morph@debian.org> Thu, 29 Jan 2015 23:25:58 +0000
python-psutil (2.1.1-1) unstable; urgency=medium
* New upstream release; thanks to Barry Warsaw for the report; Closes: #741291
* debian/rules
- remove obsolete get-orig-source target
- build explicitly else the upstream Makefile is used
* Switch to dh_python2; Closes: #637382
* debian/copyright
- switch to DEP-5 format
* debian/control
- switch me to Maintainer (team to Uploaders)
* debian/{control, rules}
- build and install documentation
* debian/python-psutil.doc-base
- added Doc base registration
* debian/patches/remove-google-analytics.patch
- remove Google Analytics tracking from documentation
-- Sandro Tosi <morph@debian.org> Sun, 04 May 2014 22:59:15 +0200
python-psutil (1.2.1-1) unstable; urgency=low
* New upstream release
* debian/copyright
- extended packaging copyright years
* debian/control
- bump Standards-Version to 3.9.5 (no changes needed)
-- Sandro Tosi <morph@debian.org> Thu, 02 Jan 2014 12:22:23 +0100
python-psutil (1.1.3-1) unstable; urgency=low
* New upstream release; thanks to Barry Warsaw for the report; Closes: #729061
-- Sandro Tosi <morph@debian.org> Sat, 09 Nov 2013 11:23:40 +0100
python-psutil (1.1.2-1) unstable; urgency=low
* New upstream release
-- Sandro Tosi <morph@debian.org> Fri, 01 Nov 2013 12:53:51 +0100
python-psutil (1.1.1-1) unstable; urgency=low
* New upstream release
* debian/watch
- point download location to PyPI
* debian/copyright
- update download URL
-- Sandro Tosi <morph@debian.org> Sat, 12 Oct 2013 15:42:08 +0200
python-psutil (1.0.1-1) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Sandro Tosi ]
* Upload to unstable
* New upstream release
* debian/control
- bump Standards-Version to 3.9.4 (no changes needed)
-- Sandro Tosi <morph@debian.org> Fri, 27 Sep 2013 07:17:13 +0200
python-psutil (0.7.0-1) experimental; urgency=low
* New upstream release
* debian/rules
- fix syntax error when executing the test suite; thanks to Julian Taylor
for the report; Closes: #687316
* debian/copyright
- extended packaging copyright years
-- Sandro Tosi <morph@debian.org> Sat, 13 Apr 2013 19:28:13 +0200
python-psutil (0.6.1-2) experimental; urgency=low
* debian/rules
- refactor build and test targets
* debian/{control, rules}
- provide Python 3 package; Closes: #636526
-- Sandro Tosi <morph@debian.org> Tue, 28 Aug 2012 21:52:43 +0200
python-psutil (0.6.1-1) experimental; urgency=low
* New upstream release
-- Sandro Tosi <morph@debian.org> Thu, 16 Aug 2012 19:22:23 +0200
python-psutil (0.6.0-1) experimental; urgency=low
* New upstream release
* debian/copyright
- extend packaging copyright years
* debian/rules
- use hardening flags
-- Sandro Tosi <morph@debian.org> Mon, 13 Aug 2012 21:58:48 +0200
python-psutil (0.5.1-1) unstable; urgency=low
* New upstream release
-- Sandro Tosi <morph@debian.org> Fri, 29 Jun 2012 19:07:24 +0200
python-psutil (0.5.0-1) unstable; urgency=low
* New upstream release
* debian/docs, python-psutil.doc-base
- removed, docs no longer provided in the tarball
* debian/control
- bump Standards-Version to 3.9.3 (no changes needed)
-- Sandro Tosi <morph@debian.org> Thu, 28 Jun 2012 22:54:28 +0200
python-psutil (0.4.1-1) unstable; urgency=low
* New upstream release
* debian/watch
- fix to correctly scan google code
-- Sandro Tosi <morph@debian.org> Sun, 25 Dec 2011 18:49:52 +0100
python-psutil (0.4.0-1) unstable; urgency=low
* New upstream release
* debian/python-psutil.examples
- install examples
* debian/rules
- don't compress .py files
-- Sandro Tosi <morph@debian.org> Mon, 31 Oct 2011 08:47:46 +0100
python-psutil (0.3.0+r1123-1) unstable; urgency=low
* New upstream SVN snapshot
-- Sandro Tosi <morph@debian.org> Tue, 20 Sep 2011 21:56:58 +0200
python-psutil (0.3.0+r1112-1) unstable; urgency=low
* New upstream SVN snapshot
* debian/rules
- add 'get-orig-source' target
-- Sandro Tosi <morph@debian.org> Mon, 29 Aug 2011 00:47:18 +0200
python-psutil (0.3.0-2) unstable; urgency=low
* debian/rules
- ignore (for now) tests error, so we can collect all of them
* debian/source/format
- switch to 3.0 (quilt) source format
-- Sandro Tosi <morph@debian.org> Sun, 28 Aug 2011 17:55:06 +0200
python-psutil (0.3.0-1) unstable; urgency=low
* New upstream release
* debian/control
- bump Standards-Version to 3.9.2 (no changes needed)
-- Sandro Tosi <morph@debian.org> Wed, 03 Aug 2011 17:29:35 +0200
python-psutil (0.2.1-1) unstable; urgency=low
* New upstream release
* debian/copyright
- extended packaging copyright years
* debian/rules
- use the correct PYTHONPATH when running tests, for all supported versions
* debian/control
- it now contains also extensions, so it's an arch:any package
- move python-support from b-d-i to b-d
- we now need python-all-dev in b-d
- added procps to b-d, needed to run tests
* debian/{control, pyversion}
- removed pyversion, replaced by XS-P-V field
-- Sandro Tosi <morph@debian.org> Mon, 04 Apr 2011 20:26:42 +0200
python-psutil (0.2.0-1) experimental; urgency=low
* New upstream release
* debian/control
- bump Standards-Version to 3.9.1 (no changes needed)
* debian/python-psutil.doc-base
- added doc-base
-- Sandro Tosi <morph@debian.org> Mon, 15 Nov 2010 20:45:35 +0100
python-psutil (0.1.3-1) unstable; urgency=low
* New upstream release
* debian/control
- bump Standards-Version to 3.8.4 (no changes needed)
* debian/rules
- adjust tests list
-- Sandro Tosi <morph@debian.org> Wed, 10 Mar 2010 23:27:55 +0100
python-psutil (0.1.2-2) unstable; urgency=low
* debian/rules
- fixed bashism in selecting tests to run; thanks to Raphael Geissert for
the report; Closes: #535411
* debian/control
- bump Standards-Version to 3.8.2 (no changes needed)
- bump b-d on debhelper to >= 7.2.18 to support Python 2.6 transition
-- Sandro Tosi <morph@debian.org> Fri, 03 Jul 2009 19:22:10 +0200
python-psutil (0.1.2-1) unstable; urgency=low
* Initial release (Closes: #527594)
-- Sandro Tosi <morph@debian.org> Sat, 16 May 2009 09:17:55 +0200
|