File: changelog

package info (click to toggle)
python-pyeclib 1.6.0-6
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 7,628 kB
  • sloc: python: 2,334; ansic: 980; sh: 127; makefile: 30
file content (250 lines) | stat: -rw-r--r-- 8,060 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
python-pyeclib (1.6.0-6) unstable; urgency=medium

  * d/tests/encode-decode.py: Fix typo.

 -- Ondřej Nový <onovy@debian.org>  Mon, 13 Jan 2020 21:21:22 +0100

python-pyeclib (1.6.0-5) unstable; urgency=medium

  * d/tests: Run on all Python versions.
  * d/tests/encode-decode.py: Merge changes from Ubuntu:
    - Ensure the tests against isa_* are well skipped for no-64 bit machines.
    - Rework test as return can't be used outside a function.

 -- Ondřej Nový <onovy@debian.org>  Sun, 12 Jan 2020 16:10:24 +0100

python-pyeclib (1.6.0-4) unstable; urgency=medium

  * Running wrap-and-sort -bast.
  * Bump Standards-Version to 4.4.1.
  * Add arm64 support for libisal.

 -- Ondřej Nový <onovy@debian.org>  Mon, 21 Oct 2019 15:59:31 +0200

python-pyeclib (1.6.0-3) unstable; urgency=medium

  * Use nosetests for running tests (same as upstream)
  * Skip test_get_metadata_memory_usage (doesn't work on mips64el)

 -- Ondřej Nový <onovy@debian.org>  Thu, 18 Jul 2019 18:37:45 +0200

python-pyeclib (1.6.0-2) unstable; urgency=medium

  * Bump required version of liberasurecode-dev to 1.6.0

 -- Ondřej Nový <onovy@debian.org>  Thu, 18 Jul 2019 15:17:27 +0200

python-pyeclib (1.6.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * New upstream release
  * Running wrap-and-sort -bast.
  * d/copyright: Bump my copyright year.
  * Bump Standards-Version to 4.4.0 (no changes needed)
  * Drop Python 2 support
  * Use pybuild for building package
  * Bump debhelper compat level to 12 and use debhelper-compat

  [ Thomas Goirand ]
  * Remove Julien, Mehdi and Goneri from uploaders (Closes: #928568).

 -- Ondřej Nový <onovy@debian.org>  Tue, 16 Jul 2019 20:25:21 +0200

python-pyeclib (1.5.0-4) unstable; urgency=medium

  * d/control:
    - Use team+openstack@tracker.debian.org as maintainer
    - Build depend on libisal on amd64 archs to run unit tests during build
    - Build depend on libjerasure to run unit tests during build
  * d/rules: Remove useless debhelper overrides
  * Standards version is 4.2.1 now (no changes)

 -- Ondřej Nový <onovy@debian.org>  Mon, 01 Oct 2018 15:05:06 +0200

python-pyeclib (1.5.0-3) unstable; urgency=medium

  * d/tests/*: Don't run encode/decode tests for isa_* ec types on non-amd64
    architures because libisal2 is not available for non-amd64 architectures.
    (Closes: #898733)
  * Add upstream metadata

 -- Ondřej Nový <onovy@debian.org>  Wed, 16 May 2018 12:29:30 +0200

python-pyeclib (1.5.0-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Updating standards version to 4.1.4
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Bump my copyright year
  * d/control:
    - Add trailing tilde to min version depend to allow backports
    - Move python3-six from python-pyeclib Depends to python3-pyeclib Depends
      (Closes: #898455)
  * Bump debhelper compat level to 11

 -- Ondřej Nový <onovy@debian.org>  Mon, 14 May 2018 13:13:18 +0200

python-pyeclib (1.5.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * New upstream release
  * (Build-)Depend on python-six
  * d/p/Prevent_division_by_zero_in_tests.patch: Removed, applied upstream
  * d/tests: Bump required version of libjerasure2
  * Enable hardening

  [ Daniel Baumann ]
  * Updating vcs fields.
  * Updating copyright format url.
  * Running wrap-and-sort -bast.
  * Updating maintainer field.
  * Removing gbp.conf, not used anymore or should be specified in the
    developers dotfiles.
  * Updating standards version to 4.0.1.

 -- Ondřej Nový <onovy@debian.org>  Sun, 06 Aug 2017 19:57:36 +0200

python-pyeclib (1.4.0-2) unstable; urgency=medium

  * Prevent division by zero in tests (patch from upstream)

 -- Ondřej Nový <onovy@debian.org>  Sun, 25 Dec 2016 21:01:35 +0100

python-pyeclib (1.4.0-1) unstable; urgency=medium

  * New upstream release
  * Bump debhelper version to 10
  * debian/tests/control: Add isa_l_rs_cauchy backend test

 -- Ondřej Nový <onovy@debian.org>  Tue, 13 Dec 2016 23:30:09 +0100

python-pyeclib (1.3.1-1) unstable; urgency=medium

  * New upstream release
  * Removed Pre-Depends on dpkg

 -- Ondřej Nový <onovy@debian.org>  Sat, 08 Oct 2016 20:28:22 +0200

python-pyeclib (1.2.1-2) unstable; urgency=medium

  * d/{control,copyright}: Use my @debian.org email address
  * Fixed .gitreview file
  * d/s/options: extend-diff-ignore of .gitreview
  * d/control: Using OpenStack's Gerrit as VCS URLs.

 -- Ondřej Nový <onovy@debian.org>  Fri, 23 Sep 2016 21:03:05 +0200

python-pyeclib (1.2.1-1) unstable; urgency=medium

  * New upstream release
  * Upstream moved to official Openstack project
  * Bump liberasurecode-dev dependency to 1.2.0 version
  * Added Flat XOR HD backend to Debian test
  * Print debug info in Debian test

 -- Ondřej Nový <novy@ondrej.org>  Thu, 02 Jun 2016 12:49:11 +0200

python-pyeclib (1.2.0-2) unstable; urgency=medium

  * Tests liberasure backends in Debian tests.
  * Removed Suggests libjerasure2.
  * Standards-Version is 3.9.8 now (no change).

 -- Ondřej Nový <novy@ondrej.org>  Fri, 08 Apr 2016 23:38:18 +0200

python-pyeclib (1.2.0-1) unstable; urgency=medium

  * New upstream release.
  * Added Suggests libjerasure2.
  * Added Debian tests.
  * Added myself as uploader.
  * Added myself to copyright file.
  * Fixed Vcs URLs.
  * Removed patch: disable-check-for-liberasure-code.patch
  * Removed patch: more-rpath-tweak-removal.patch
  * Removed install-liberasurecode=no option, it's not needed anymore.
  * Fixed d/copyright.
  * Standards-Version is 3.9.7 now (no change).

 -- Ondřej Nový <novy@ondrej.org>  Fri, 26 Feb 2016 22:29:07 +0100

python-pyeclib (1.1.1-2) unstable; urgency=medium

  * Rebuild with liberasurecode 1.1.0.

 -- Thomas Goirand <zigo@debian.org>  Fri, 11 Dec 2015 23:54:00 +0000

python-pyeclib (1.1.1-1) unstable; urgency=medium

  * New upstream release.
  * Add --install-liberasurecode=no when installing with "python setup.py
    install".
  * Drop version of python-all-dev build-depends.
  * Dropped big-endian.patch applied upstream.
  * Rebased patches:
    - disable-check-for-liberasure-code.patch
    - more-rpath-tweak-removal.patch
  * Overrides dh_auto_install, not dh_install.

 -- Thomas Goirand <zigo@debian.org>  Tue, 10 Nov 2015 11:08:06 +0000

python-pyeclib (1.0.8-3) unstable; urgency=medium

  * Team upload.
  * Drop BD's on gf-complete and jerasure dev packages; not required
    due to the runtime nature of backend loading in liberasurecode.
  * d/p/big-endian.patch: Cherry pick fix from upstream VCS to resolve
    issues on big endian architectures.

 -- James Page <james.page@ubuntu.com>  Wed, 09 Sep 2015 13:32:08 +0100

python-pyeclib (1.0.8-2) unstable; urgency=medium

  * Team upload.
  * Match version of liberasurecode-dev with pyeclib.

 -- James Page <james.page@ubuntu.com>  Thu, 06 Aug 2015 14:19:02 +0100

python-pyeclib (1.0.8-1) unstable; urgency=medium

  [ James Page ]
  * d/rules: Enable unit testing for python2.

  [ Thomas Goirand ]
  * New upstream release.
  * Rebased patches.

 -- Thomas Goirand <zigo@debian.org>  Wed, 05 Aug 2015 08:35:22 +0000

python-pyeclib (1.0.7m-1) unstable; urgency=medium

  * New upstream release.
  * Added dh-python as build-depends.

 -- Thomas Goirand <zigo@debian.org>  Sun, 17 May 2015 05:55:24 +0200

python-pyeclib (1.0.5m-1) unstable; urgency=medium

  * New upstream release using liberasurecode 1.0.5.
  * Refreshed patches.

 -- Thomas Goirand <zigo@debian.org>  Fri, 13 Mar 2015 23:23:29 +0000

python-pyeclib (0.9.10-3) unstable; urgency=medium

  * Fixed the debian/watch file to use the URL from bitbucket.

 -- Thomas Goirand <zigo@debian.org>  Sun, 08 Mar 2015 18:41:06 +0000

python-pyeclib (0.9.10-2) unstable; urgency=medium

  * Added missing python{3,}-all-dev build-depends.
  * Added missing libjerasure-dev build-depends.

 -- Thomas Goirand <zigo@debian.org>  Thu, 20 Nov 2014 02:15:48 +0800

python-pyeclib (0.9.10-1) unstable; urgency=low

  * Initial release. (Closes: #769519)

 -- Thomas Goirand <zigo@debian.org>  Fri, 14 Nov 2014 17:37:50 +0800