1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131
|
Source: python-pyhsm
Maintainer: Debian Authentication Maintainers <pkg-auth-maintainers@lists.alioth.debian.org>
Uploaders: Simon Josefsson <simon@josefsson.org>, Klas Lindfors <klas@yubico.com>, Dain Nilsson <dain@yubico.com>
Section: python
Priority: optional
Build-Depends: python-setuptools (>= 0.6b3),
debhelper (>= 9),
python
Standards-Version: 3.9.8
Homepage: https://developers.yubico.com/python-pyhsm/
Vcs-Browser: https://github.com/Yubico/python-pyhsm-dpkg
Vcs-Git: https://github.com/Yubico/python-pyhsm-dpkg.git
Package: python-pyhsm
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
python-crypto,
python-serial
Suggests: python-argparse,
yhsm-daemon
Recommends: yhsm-tools
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: Python code for talking to a Yubico YubiHSM hardware
YubiHSM is an easy to use and affordable crypto appliance
that you connect to the USB port of a server. You can then
store cryptographic keys on the YubiHSM and use them from the
server without any possibility for an attacker to extract
the crypto keys from the YubiHSM.
.
Supported operations include YubiKey OTP validation, AES ECB
encrypt/decrypt/decrypt-compare, HMAC-SHA1 hashing (enabling OATH code
validation), and Random number entropy generation.
.
This package contains the core Python code for interacting with the
YubiHSM.
Package: yhsm-tools
Section: utils
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
python-argparse,
python-setuptools,
python-pyhsm (= ${binary:Version})
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: Common files for YubiHSM applications
YubiHSM is an easy to use and affordable crypto appliance
that you connect to the USB port of a server. You can then
store cryptographic keys on the YubiHSM and use them from the
server without any possibility for an attacker to extract
the crypto keys from the YubiHSM.
.
Supported operations include YubiKey OTP validation, AES ECB
encrypt/decrypt/decrypt-compare, HMAC-SHA1 hashing (enabling OATH code
validation), and Random number entropy generation.
.
This package includes the following utilities that talk with the YubiHSM:
.
* yhsm-keystore-unlock - Keystore unlock
* yhsm-linux-add-entropy - Entropy seeder
* yhsm-decrypt-aead - Decrypt AEADs
* yhsm-generate-keys - Generate new AEADs
Package: yhsm-validation-server
Section: net
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
adduser,
lsb-base,
python-pyhsm (= ${binary:Version}),
python-argparse,
python-setuptools,
yhsm-tools
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: Validation server using YubiHSM
This package validates YubiKey OTP's, OATH codes or password hashes
using YubiHSM.
.
The interface is a REST API with a simple web server listening on
localhost only (per default). It can function as a drop-in replacement
for the traditional PHP based Yubico validation server, except that
it does not provide the advanced replication features of that server.
Package: yhsm-yubikey-ksm
Section: net
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
adduser,
lsb-base,
python-pyhsm (= ${binary:Version}),
python-argparse,
yhsm-tools,
python-setuptools,
python-daemon,
python-sqlalchemy,
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: Yubikey Key Storage Module using YubiHSM
Decryption backend for a Yubico validation service. Uses the
YubiHSM to decrypt YubiKey OTPs and answer 'OK' or 'ERR'.
.
This package provides the decryption backend for a Yubico validation
service. It uses the YubiHSM to decrypt YubiKey OTPs and answer 'OK'
or 'ERR'. The package also contains the yhsm-db-import and
yhsm-db-export tools for database management.
Package: yhsm-daemon
Section: net
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
adduser,
lsb-base,
python-pyhsm (= ${binary:Version}),
python-argparse,
python-setuptools,
python-daemon
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: YubiHSM server daemon
Provides a TCP based server allowing multiple processes to use a
single YubiHSM in parallel.
.
To utilize the YubiHSM via the server instead of using it directly,
pass yhsm://localhost:5348 as the device to python-pyhsm.
|