1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
PYTHONS:=$(shell pyversions -vr)
PYTHON3S:=$(shell py3versions -vr)
UPSTREAM_GIT = git://github.com/lxc/pylxd.git
include /usr/share/openstack-pkg-tools/pkgos.make
export OSLO_PACKAGE_VERSION=$(shell dpkg-parsechangelog | grep Version: | cut -d' ' -f2 | sed -e 's/^[[:digit:]]*://' -e 's/[-].*//' -e 's/~/.0/' | head -n 1)
%:
dh $@ --buildsystem=python_distutils --with python2,python3,sphinxdoc
override_dh_auto_install:
set -e ; for pyvers in $(PYTHONS); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python-pylxd; \
done
set -e ; for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python3-pylxd; \
done
rm -f $(CURDIR)/debian/python*/usr/lib/python*/dist-packages/*.pth
override_dh_auto_clean:
rm -rf build
rm -rf .testrepository
find . -iname '*.pyc' -delete
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=$(CURDIR) sphinx-build $(SPHINXOPTS) -b html doc/source $(CURDIR)/debian/python-pylxd-doc/usr/share/doc/python-pylxd-doc/html
dh_sphinxdoc -O--buildsystem=pybuild
endif
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
nosetests -v pylxd.deprecated.tests
nosetests3 -v pylxd.deprecated.tests
endif
|