1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
|
export PYBUILD_NAME=pyramid
export pkgversion=$(shell dpkg-parsechangelog --show-field version)
%:
dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install
cd $(CURDIR)/debian/python3-pyramid/usr/bin; \
for file in * ; do \
mv $${file} $${file}3; \
done
find $(CURDIR)/debian -name \*.pdf -exec chmod -x {} \;
override_dh_installman:
mkdir -p $(CURDIR)/debian/manpages
cd $(CURDIR)/debian/python-pyramid/usr/bin; \
export PYTHONPATH=$(CURDIR); \
set -x; \
for file in *; do \
help2man --version-string=$${pkgversion} \
--no-info --section=1 \
--name="Python 2 Pyramid command" \
--output=$(CURDIR)/debian/manpages/$${file}.man \
--no-discard-stderr \
./$${file}; \
done
mkdir -p $(CURDIR)/debian/manpages3
cd $(CURDIR)/debian/python3-pyramid/usr/bin; \
export PYTHONPATH=$(CURDIR); \
set -x; \
for file in *; do \
help2man --version-string=$${pkgversion} \
--no-info --section=1 \
--name="Python 3 Pyramid command" \
--output=$(CURDIR)/debian/manpages3/$${file}.man \
--no-discard-stderr \
./$${file}; \
done
dh_installman
override_dh_auto_clean:
dh_auto_clean
rm -rf $(CURDIR)/debian/manpages
rm -rf $(CURDIR)/debian/manpages3
|