1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
UPSTREAM_GIT := https://github.com/openstack/reno.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3,sphinxdoc
override_dh_auto_clean:
rm -rf build .stestr *.egg-info
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
pkgos-dh_auto_test --no-py2 'reno\.tests\.(?!test_cache\.TestCache\.test_build_cache_db.*|test_semver\.TestSemVer.*)'
endif
override_dh_sphinxdoc:
mkdir -p debian/python-reno-doc/usr/share/doc/python-reno-doc/html
cp -auxf doc/source/*.rst debian/python-reno-doc/usr/share/doc/python-reno-doc/html
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
|