1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
UPSTREAM_GIT := https://github.com/sigmavirus24/rfc3986.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3
override_dh_auto_clean:
rm -rf build .stestr *.egg-info src/*.egg-info .pytest_cache
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
set -e ; for pyvers in $(PYTHON3S); do \
PYTHONPATH=.:$(CURDIR)/src PYTHON=python$$pyvers python$$pyvers -m pytest tests ; \
done
endif
|