1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
export http_proxy = http://127.0.0.1:9
UPSTREAM_GIT := https://github.com/open-iscsi/rtslib-fb.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3
override_dh_auto_clean:
rm -rf build
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
override_dh_auto_build:
echo "Do nothing..."
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
override_dh_installinit:
dh_installinit -O--buildsystem=pybuild --name rtslib-fb-targetctl
override_dh_installsystemd:
dh_installsystemd -p python3-rtslib-fb --name rtslib-fb-targetctl
|