File: .travis.yml

package info (click to toggle)
python-sh 1.14.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, sid
  • size: 668 kB
  • sloc: python: 4,614; sh: 7; makefile: 5
file content (27 lines) | stat: -rw-r--r-- 526 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
os:
    - linux

language: python

python:
    # - 2.6 No longer supported on Travis
    - 2.7
    # - 3.3 No longer supported on Travis
    - 3.4
    - 3.5
    - 3.6
    - 3.7
    - 3.8
    - pypy
    - pypy3.5

before_script:
    - pip install -r requirements-dev.txt

script:
    - python sh.py travis
    - python -m flake8 sh.py test.py
    - if python -c 'import sys; sys.exit(int(not sys.version_info >= (3, 5)))' ; then python setup.py check --restructuredtext --metadata --strict ; fi

after_success:
    - coveralls