1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
|
Source: python-sparse
Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders: Ghislain Antony Vaillant <ghisvail@gmail.com>, Diane Trout <diane@ghic.org>
Section: python
Priority: optional
Build-Depends: debhelper-compat (= 13),
dh-python,
dpkg-dev (>= 1.17.14),
python3-all,
python3-dask <!nocheck>,
python3-numba,
python3-numpy <!nocheck>,
python3-packaging <!nocheck>,
python3-pytest <!nocheck>,
python3-pytest-cov <!nocheck>,
python3-scipy (>= 0.19) <!nocheck>,
python3-six <!nocheck>,
python3-setuptools
Standards-Version: 4.5.1
Vcs-Browser: https://salsa.debian.org/python-team/packages/python-sparse
Vcs-Git: https://salsa.debian.org/python-team/packages/python-sparse.git
Homepage: https://github.com/pydata/sparse
Rules-Requires-Root: no
Package: python3-sparse
Architecture: all
Depends: ${misc:Depends},
${python3:Depends}
Description: multidimensional sparse arrays for Python
This package implements sparse multidimensional arrays on top of NumPy
and scipy.sparse. It generalizes the scipy.sparse.coo_matrix layout but
extends beyond just rows and columns to an arbitrary number of
dimensions. The original motivation is for machine learning algorithms,
but it is intended for somewhat general use.
.
It supports:
.
- NumPy ufuncs (where zeros are preserved)
- Arithmetic with scalars (where zeros are preserved)
- Reductions (sum, max)
- Reshape
- Transpose
- Tensordot
- Slicing with integers, lists, and slices (with no step value)
- Concatenation and stacking
- Addition with other sparse arrays of the same shape
.
This package provides the modules for Python 3.
|