File: setup_data.py

package info (click to toggle)
python-traitsbackendqt 3.4.0-1
  • links: PTS, VCS
  • area: main
  • in suites: squeeze
  • size: 1,312 kB
  • ctags: 1,822
  • sloc: python: 11,879; makefile: 9; sh: 5
file content (45 lines) | stat: -rw-r--r-- 1,430 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
# Function to convert simple ETS project names and versions to a requirements
# spec that works for both development builds and stable builds.  Allows
# a caller to specify a max version, which is intended to work along with
# Enthought's standard versioning scheme -- see the following write up:
#    https://svn.enthought.com/enthought/wiki/EnthoughtVersionNumbers
def etsdep(p, min, max=None, literal=False):
    require = '%s >=%s.dev' % (p, min)
    if max is not None:
        if literal is False:
            require = '%s, <%s.a' % (require, max)
        else:
            require = '%s, <%s' % (require, max)
    return require


# Declare our ETS project dependencies:
ENTHOUGHTBASE = etsdep('EnthoughtBase', '3.0.5')
ETSDEVTOOLS_DEVELOPER = etsdep('ETSDevTools[developer]', '3.0.4')
TRAITS = etsdep('Traits', '3.4.0')
TRAITSGUI = etsdep('TraitsGUI', '3.4.0')


INFO = {

    'extras_require' : {

        # Extra denoting that complete developer debug support for the ETS FBI
        # debugger should be installed:
        'debug': [
            ETSDEVTOOLS_DEVELOPER,
            ],

        # All non-ets dependencies should be in this extra to ensure users can
        # decide whether to require them or not.
        'nonets': [
            ],
        },
    'install_requires' : [
        ENTHOUGHTBASE,
        TRAITS,
        TRAITSGUI,
        ],
    'name' : 'TraitsBackendQt',
    'version' : '3.4.0',
    }