1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56
|
export PYBUILD_BEFORE_TEST=cp -r {dir}/tests {build_dir}/; cp -r {dir}/testdata {build_dir}/
export PYBUILD_TEST_ARGS=-k "not test_parse_media_file_http"
export PYBUILD_TEST_PYTEST=1
export PYBUILD_AFTER_TEST=rm -rf {build_dir}/tests {build_dir}/testdata
%:
dh "$@" --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
cd $(CURDIR)/doc && $(MAKE) html
override_dh_auto_clean:
dh_auto_clean
cd $(CURDIR)/doc && $(MAKE) clean
rm -rf $(CURDIR)/python_twitter.egg-info
rm -rf $(CURDIR)/.eggs
override_dh_compress:
dh_compress -X.js -X.inv
override_dh_sphinxdoc:
(! test -d $(CURDIR)/debian/python-twitter-doc || dh_sphinxdoc)
|